Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace

Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus SVT > Focus SVT > speedo problem

Focus SVT The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the MK1 2002-2004 Focus SVT.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Thread: speedo problem Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Pitch Black ZX3
Your real name.
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-04-2013 06:55 AM
02fordsvt My first guess is that the needle is rubbing against the gauge face. To fix that, open up the gauge cluster and pull the needle out slightly until it starts moving freely again.

You'll probably have to recalibrate the needle when you done but here's a link on how to do that:
02-03-2013 01:53 PM
speedo problem

Has anyone else ever had a problem with there speedo guade sticking. On my svt foci when I am driving the speedo needle moves smooth until about 20-25 mph and then it will start sticking and jumping about every 10 mph as the speed increases. Not sure what causes this or if there is a fix for it. Not really a major problem but I would just like to have a speedometer that works properly.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

All times are GMT -5. The time now is 10:00 AM.

Copyright 2002-2015 All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.


Search Engine Optimization by vBSEO 3.6.1