Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > Car Audio, SYNC, MyFord Touch & Electronics > jumped my car, no power now

Car Audio, SYNC, MyFord Touch & Electronics The Forum for the Ford Focus audiophiles. The place to chat about automobile sound systems, security systems, or show off your I.C.E.!
Sponsored By: GT Sound Control


Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: jumped my car, no power now Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-07-2013 03:36 PM
stealthzx3 Good deal, cars are strange.
02-07-2013 03:02 PM
Blackstealth03 Checked all the connections from the headunit to the factory harness was all good. Took my battery off for 30 sec, hooked back up and its working.
02-04-2013 08:45 PM
stealthzx3 I'd check the wiring. Is the factory wiring harness still there, or was another one spliced on by you or another owner?
02-02-2013 02:30 PM
TheGlassMaker My guess is you have a short some where. I hope someone can chime in to help with you situation better.
02-02-2013 02:04 PM
Blackstealth03 Not sure what caused it, radio worked for about 5 min then my car stalled(while moving) and no radio. I looked behind it, everything seems intact.
02-02-2013 01:04 PM
TheGlassMaker What happened to cause the car to die? Did you check for a short in a wire behind the radio?
02-02-2013 12:58 PM
Blackstealth03
jumped my car, no power now

So my car died the other night, got it jumped and now my headunit isn't getting power. I checked the fuse that's in the unit and their still good. Pulled a couple fuses at the panel and their good as well. Any thoughts of what's going on?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:06 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.