Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Second Generation > MK2 Focus > Reverse bulb questions

MK2 Focus The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the second generation 2008-2011 Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Reverse bulb questions Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-07-2013 10:54 AM
Justinr666 yea... it had nothing to do with the polarity of the LED's.. as my old filimant bulb wasnt working while in the socket... i did rotate the bulb, and found that once i rotated it, i had to jiggle it around for it to light up... both the old bulb and new bulb didnt sit inside the socket tightly, where as the drivers side, it was a snug fit. i figure the contacts had worn out, and didnt have the "spring" in them anymore... which makes me think that all of you with stock tail lights should check your reveres to make sure they work. Also i ended up getting the part about 20min ago from NAPA... reason is it was only $20, ford offers it for $16... so its not an expensive piece thank god. though, the old socket is a pain to get off for anyone who has to do it... its fused all the way around from dirt and salt. a small flat head helps!
02-07-2013 10:42 AM
DarderSauce Throw up a pic of the broken tabs.

Just a thought, did you try putting the LED in both ways (insert, test, rotate 180*, insert, test) I thought one of mine was fried until I remembered LED bulbs can't go in backwards like the OEM bulbs.

Just a thought, sorry if you already tried this. Also, if you can't find a second gen and the part is the same as I am thinking I have a Junkyard near me with some second gen Foci. I could possibly pull the part for you if it works $$ wise.
02-05-2013 01:28 PM
Justinr666 So, i got my bulbs in the mail, started installing them today. Got the drivers side installed with out a problem, they look great.. but when i went to do the passenger side.. i noticed my old bulb wasnt lit up.. and when i went to take it out, i saw it was a bit loose... upon clser inspection i figured out it was because the contacts in the socket were broken.. for some reason the contacts had broken at some point. I will point out this is the first time i had taken out this bulb. So.. now i am left with a broken reverse light and was wondering is the 1 gen focus has the same socket as ours? if so im going to a junk yard and going to get me a new one
01-24-2013 10:40 PM
Dukttape The reverse lights I have are 9W LEDs. They're 921s. As for interior lights including the trunk are 194 so if your going to LEDs they're T10 bases.
01-24-2013 10:28 PM
Justinr666 i am thinking that what i will have to do. because the 3441 bulb just doesnt seem right.. thank you for the help
01-24-2013 10:07 PM
Kipp everything i'm showing doesn't look like it's correct. it might be the 3886x bulb, but not sure. i haven't looked at mine in a while since i don't drive the car much. you can always pull the bulbs and take them to an auto parts store and compare to find out what they are.
01-24-2013 10:01 PM
Kipp i think the dome is a 941 if i remember right. give me a minute and i'll find out
01-24-2013 09:52 PM
Justinr666 alright, so i found the correct bulb for the reverse lights, thank you kipp. But, the bulb that sylvania says to use for the map light/trunk light is a 6411 bulb... almost the same as the plate light. But i swear when i took apart my dome light it was a wedge type assembly? any thoughts?
01-24-2013 07:42 PM
Kipp you need to find a 921 bulb. i think it's the same as a 07, but not 100% on that
01-24-2013 07:37 PM
Justinr666
Reverse bulb questions

so i am on ebay right now looking for reverse bulbs, i know our car is wedge type, but all the ones i like say they arent compatible with the 08 focus... 07 and below. So my question is will an 07 work in our gen? i was going to order one from andysautosport... until i saw they wanted $40 to ship to me... twice what the lights are worth! so any help from you guys will be awesome! thanks in advance

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:59 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Cadillac ATS-V, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.