Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Second Generation > MK2 Focus > 08 focus low beam and high beam fault

MK2 Focus The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the second generation 2008-2011 Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: 08 focus low beam and high beam fault Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-27-2013 08:17 AM
gtferrari The lowbeams have seperate fuses one for each side and a shared fuse for highbeams. Located under dash. Weird that the connection would be bad. With the locking mechanism and seals. I would check to see if anything has melted.
01-26-2013 10:43 AM
Kurtsmith2013 High beam gone again :/ must be loose connections on the headunit itself, new headlight bulbs are here :) fitting tuesday as im off :)
01-24-2013 08:26 AM
Urbanspacedude91 Cheers to the working headlight
01-23-2013 03:57 PM
Kurtsmith2013 I took headlight out pushed connectors in and high beam works headlight has blown :)
01-23-2013 03:47 PM
Urbanspacedude91 Its most likely that there is a short or loose connection somewhere in the drivers side. What i would do is start from the connection and work your way down. I wouldnt even bother checking the fuse becuase if the fuse was blown they both would be out not just one.
01-23-2013 02:46 PM
Kurtsmith2013
08 focus low beam and high beam fault

My low beam and high beam arnt working on drivers side but the sidelight is? Any help please

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:14 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat