Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat > Odd problem, car dies.

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Odd problem, car dies. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-02-2013 09:50 AM
WEMKAY I can say with few reservations that this has indeed solved the problem, meaning the problem was electrical in nature.

Thanks for the ideas that were PM'd to me. It was unrelated to the power steering or fuel system as some suspected.

I'm sure I'll have a few more mysteries in the future. This is my first post-2000 vehicle and I'm quickly learning that It's no longer as simple as taking a look under the hood. I miss my 80's and 90's cars. You could diagnose a problem with those quickly.
12-31-2012 08:39 PM
WEMKAY Got the car back. Replaced pos/neg terminals and wiring. Paid too much. Fingers crossed
12-30-2012 12:00 PM
WEMKAY Don't know if this could be related, but I had a similar problem a while back where the car would refuse to start... We ended up cleaning off the negative and positive terminals and the negative ground and boom everything back to normal.

The wires and positive terminals are pretty corroded. Think that could be related?
12-30-2012 12:50 AM
WEMKAY I think I'm just gonna drop it off at a Ford dealership tomorrow and pay the man to fix it.
12-29-2012 11:38 PM
WEMKAY
Odd problem, car dies.

When I turn all the way to the left or right while moving the ! Light turns on and sometimes the car dies. But if I make the turn slowly or if the car is stopped It's just fine.

I'm getting tired of this car and I still have $4500 on the loan to pay.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:19 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat