Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat > Engine light and no power steering?

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Engine light and no power steering? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-07-2012 03:22 AM
amc49 A pulley could have locked up belt for a second until it freed back up, I'd be checking those pulleys and tensioner.
12-06-2012 01:11 PM
rockabillyrebeljim Hi, the serp belt is still there. It went in the summer so I replaced it so its pretty new. The tension seems fine as well.
Thanks
12-06-2012 01:04 PM
6SPD_soul Sounds like your serpentine belt might not be there anymore, I'd check that first.
12-06-2012 12:44 PM
rockabillyrebeljim
Engine light and no power steering?

Hi, i have an english 2003 1.6 focus. I was sat in traffic this morning after a 40min drive and my engine light and battery light came on as well as the power steering not working. I was literally rolling at about 1 mph. The engine stayed running but was acting a bit weird. I turned the ignition off and restarted and is was fine for 2 mins when the battery light came on for 5 seconds and went off when I blipped the throttle. I have since made the journey home and it has been fine.
Does this mean something is about to go? I changed the alternator about 6 months ago.
Thanks Jim

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:29 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat