Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus SVT > SVT Performance (2002-2004) > HOW TO: IMRC Removal and Repair

SVT Performance (2002-2004) The place to chat about any 2.0L SVT DOHC Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Thread: HOW TO: IMRC Removal and Repair Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
Today 05:23 PM
Sniper Focus Not quite...

Ford Focus SVT Powertrain Specifications
Quote:
The other significant contributor to low-speed torque is the SVT Focus dual-stage intake manifold, the first application of this technology at Ford. This device is designed to direct the intake air through four long runners below 6,000 rpm. Above 6,000 rpm, the manifold switches position to shorten the runners length, which improves peak power output.
(I was told my car has the latest factory tune and it activates at 5,000 rpm, while some do it at 6,000. I think the aftermarket tuner guy(s) sets it at 5,000 as well.)

Engine off = IMRC is free and the manifold is in short runner mode.

Idle through 5K or 6K rpm = IMRC is pulling the cable for long runner mode.

Above 5K or 6K rpm = IMRC lets go for warp speed power (short runner mode.)
Today 04:50 PM
mike1986
Quote:
Originally Posted by Sniper Focus View Post
No, the intake needs to be completely at rest when the engine is off. This is supposed to work strictly as an OPEN or CLOSED system with no stages in between. At least it looks like you've found your problem. You'll probably get performance back in the upper RPM range when the IMRC drops the lever back down to "engine off" status.
Ok I want to make sure I understand the situation.

Previously I was told by a friend that this "little open" position at "engine off" is normal, that after starting the ignition (but not the engine) the line should be automatically released from the strained position and the intake valves should be closed.

That means that I was told the following scheme:

1. Engine off + ignition off = IMRC line is strained and intake valves are about 5-10% open

2. Engine off + ignition on = IMRC line is released and intake valves are closed.

3. Engine on = the IMRC is closing/opening intake valves, depending on the RPM.

Now what you told me is:

1. Engine off + ignition off = IMRC line is free and intake valves are closed.

2. Engine off + ignition on = IMRC line is free and intake valves are closed.

3. Engine on = the IMRC is closing/opening intake valves, depending on the RPM.



Is this correct?
Today 01:36 PM
Sniper Focus
Quote:
Originally Posted by mike1986 View Post
Thanks for the replay. Yes, my lever was broken once and it's fixed with a screw. But I noticed that the "engine off" status of the line is a little bit strained, pulling the lever a little bit and keeping the valves in about ~10% open position. Is this correct? Or the valves should be completely closed when the engine is off?
No, the intake needs to be completely at rest when the engine is off. This is supposed to work strictly as an OPEN or CLOSED system with no stages in between. At least it looks like you've found your problem. You'll probably get performance back in the upper RPM range when the IMRC drops the lever back down to "engine off" status.
Today 08:04 AM
mike1986
Quote:
Originally Posted by Sniper Focus View Post
I don't have any real ideas, some slight corrosion on the main contact made my car act like that this year, I cleaned it and the code went away. Or maybe some one replaced the lever and it's in a wrong orientation...

The reason if the "lever breaks and no code" is because the position sensor is in the IMRC box. As long as the box is working it wont throw any codes, even if it's hooked up to anything or not.
Thanks for the replay. Yes, my lever was broken once and it's fixed with a screw. But I noticed that the "engine off" status of the line is a little bit strained, pulling the lever a little bit and keeping the valves in about ~10% open position. Is this correct? Or the valves should be completely closed when the engine is off?
Yesterday 09:08 PM
Sniper Focus
Quote:
Originally Posted by mike1986 View Post
Hey everyone, I own Ford Focus ST170 (2003) and since a long time I am facing IMRC problem too. The only code that comes up is P1518. I already tied a few attempts to fix it, no luck so far.

1. Firstly I replaced one of the famous transistor inside the IMRC. No problem for about a month, then P1518 came back. At the beginning the check engine light was coming back every few days. 2 days - no problem, then again check engine light for next 3 days. And again and again. What I'm trying to say is that the issue wasn't permanent.

After few more months the check engine light stayed and never went back. After removing the error code it comes back always after about 50km or 3rd engine start.

2. So I sent my IMRC for a regeneration. A lot of parts inside were changed for new ones. Regenerated IMRC was tested on the other vehicle and everything was fine. But after placing it in my car the check engine came again. So basically no difference.

3. Then I asked electrician to check the wires. He checked all IMRC cables, including the signal cable that goes to the driver. Everything is fine.

So...

* IMRC is fine
* Cables are fine too

What else can be wrong? Broken lever? Something else? I've seen an opinion somewhere that "If it's throwing a code it's a bad IMRC, if the lever breaks you don't get a code". That confused me a lot.

Any opinions/solutions? Thanks in advance!
I don't have any real ideas, some slight corrosion on the main contact made my car act like that this year, I cleaned it and the code went away. Or maybe some one replaced the lever and it's in a wrong orientation...

The reason if the "lever breaks and no code" is because the position sensor is in the IMRC box. As long as the box is working it wont throw any codes, even if it's hooked up to anything or not.
Yesterday 08:46 PM
Sniper Focus
Quote:
Originally Posted by reddy1 View Post
Awesome thanks sniper! So I kinda assumed it was broken/ hoped because I didnt want to open up the actual irmc. So I actually got a billet one from cfm can you give me pointers on how to take the old one off and where the wire attaches to the new one is the plastic do-hicky what I put in the lever or?
There's even a link for a "how to" in post #2.
http://www.focusfanatics.com/forum/g...lp-please.html

It's been a while since I've done, I remember the annoying part of having to "hammer" it on in a limited space. Tapping on it cuts new splines in the lever. Also shifting into a certain gear moves the shifter linkage out of the way for more working room in that area.
Yesterday 06:49 PM
reddy1 Awesome thanks sniper! So I kinda assumed it was broken/ hoped because I didnt want to open up the actual irmc. So I actually got a billet one from cfm can you give me pointers on how to take the old one off and where the wire attaches to the new one is the plastic do-hicky what I put in the lever or?
Yesterday 06:06 PM
Sniper Focus
Quote:
Originally Posted by reddy1 View Post
I got this car used I am trying to figure out what the heck the last guy did the electric connection was pulled out of the imrc and so I have been trying a bunch of stuff I have some pictures of the current state trying to figure out if the original clip is broken or what (wondering if maybe its just fine and they unattached that too) because if so I need to figure out how to attach it. ( I have never seen it attached since I got it used and cant find any close ups of this) and I also probably just need to do the normal pull everything apart and sand the piece that normally gets messed up. Any help would be super awesome thank you.
I figure people on this post should be able to clarify this for me thank you all for
The lever is definitely broken.
CFM Billet Intake Manifold Lever for '02-04 SVT/ST170 Focus

I don't know if you can get the original plastic one from Ford, if so it might not be too much cheaper. I had the billet one on my car for a few years.
Yesterday 05:59 PM
reddy1 I got this car used I am trying to figure out what the heck the last guy did the electric connection was pulled out of the imrc and so I have been trying a bunch of stuff I have some pictures of the current state trying to figure out if the original clip is broken or what (wondering if maybe its just fine and they unattached that too) because if so I need to figure out how to attach it. ( I have never seen it attached since I got it used and cant find any close ups of this) and I also probably just need to do the normal pull everything apart and sand the piece that normally gets messed up. Any help would be super awesome thank you.
I figure people on this post should be able to clarify this for me thank you all for
05-23-2015 01:01 PM
mike1986 Hey everyone, I own Ford Focus ST170 (2003) and since a long time I am facing IMRC problem too. The only code that comes up is P1518. I already tied a few attempts to fix it, no luck so far.

1. Firstly I replaced one of the famous transistor inside the IMRC. No problem for about a month, then P1518 came back. At the beginning the check engine light was coming back every few days. 2 days - no problem, then again check engine light for next 3 days. And again and again. What I'm trying to say is that the issue wasn't permanent.

After few more months the check engine light stayed and never went back. After removing the error code it comes back always after about 50km or 3rd engine start.

2. So I sent my IMRC for a regeneration. A lot of parts inside were changed for new ones. Regenerated IMRC was tested on the other vehicle and everything was fine. But after placing it in my car the check engine came again. So basically no difference.

3. Then I asked electrician to check the wires. He checked all IMRC cables, including the signal cable that goes to the driver. Everything is fine.

So...

* IMRC is fine
* Cables are fine too

What else can be wrong? Broken lever? Something else? I've seen an opinion somewhere that "If it's throwing a code it's a bad IMRC, if the lever breaks you don't get a code". That confused me a lot.

Any opinions/solutions? Thanks in advance!
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:10 PM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1