Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat > need help got some problems with my svt

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: need help got some problems with my svt Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-16-2012 08:19 PM
hEaT
Quote:
Originally Posted by sally03svt View Post
Both wheels did wobble a little when in the air tie rods and cv joints seemed to be ok had the car since feb of this year havent had an alignment since ive had it.
Was the wheel locked? Was there any play in the joints themselves? When inner tie rods go you'll get a similar pull on accel and decel. Get an alignment and they'll tell you if they can't due to worn parts.
11-16-2012 08:02 PM
sally03svt Both wheels did wobble a little when in the air tie rods and cv joints seemed to be ok had the car since feb of this year havent had an alignment since ive had it.
11-16-2012 07:45 PM
tukaniSVT ** Moved to the General Tech Chat Area **

Sounds like your car may have an alignment issue.

When was the last time you aligned your car?

If recent, check your tie-rods and CV Joints and make sure you don't have any major wobble on your front wheels with the car up in the air. Also look at the top hat of your front suspension and make sure that doesn't move when you have in the air also.

Ray
11-16-2012 05:39 PM
sally03svt
need help got some problems with my svt

Well my car wants to pull hard to the left our right when i accelerate our when i go around turns. it sucks and im afraid its going to cause an accident cause it turns very hard left our right gotta fight every time i turn. ihave zx3 rims with 205 55 r16 on them pretty much my winter tires and rims it never happened when i had rims on it d

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:44 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat