Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Third Generation > DURATEC Ti-VCT Performance (2012-Current) > Help !! Weird thing happened last night

DURATEC Ti-VCT Performance (2012-Current) The place to chat about any Duratec 2.0L Ti-VCT engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Help !! Weird thing happened last night Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-04-2012 11:50 PM
Raceredrudy Thanks guys
11-04-2012 04:00 PM
cbdallas No point in losing a perfectly good socket. Take a few bolts out of the tray & reach in and grab it.
11-04-2012 03:54 PM
dyn085
Quote:
Originally Posted by Raceredrudy View Post
Update : I put the lid back on the air filter and light went away.

But like a moron , when tightening the last screw in -- the stupid socket fell off the screwdriver and fell into the depths of the unknown.

Is this a problem or should the socket fall out eventually ? Thanks guys
It will eventually fall out if it got down to the tray. Smack the belly tray a few times and you'll hear it if it did.

It would be best if you dropped the tray and pulled it out. If that comes out while you're at speed it can wreak some havoc on the car behind you...
11-04-2012 03:20 PM
Raceredrudy Update : I put the lid back on the air filter and light went away.

But like a moron , when tightening the last screw in -- the stupid socket fell off the screwdriver and fell into the depths of the unknown.

Is this a problem or should the socket fall out eventually ? Thanks guys
11-04-2012 12:32 PM
TiStick
Quote:
Originally Posted by dyn085 View Post
No. Flippin. Clue.

If the CEL is on, I would limp it back to the dealer. If you feel it isn't safe to drive, contact the dealership and have them tow it under warranty.

If the car is normal again, I would consider having the video camera handy and in the glove box. Obviously that doesn't help right now, but should it happen again in the future you will be able to document what is happening in a manner that the dealership will have to acknowledge it.
This.

I keep a 7mp point and shoot that also takes video/sound in my glovebox(aka. the black hole) for this very purpose.

OP,If you can make it to Autozone/Advance/whatever you have in your area, they will be able to read the code for you.
11-04-2012 11:58 AM
dyn085 No. Flippin. Clue.

If the CEL is on, I would limp it back to the dealer. If you feel it isn't safe to drive, contact the dealership and have them tow it under warranty.

If the car is normal again, I would consider having the video camera handy and in the glove box. Obviously that doesn't help right now, but should it happen again in the future you will be able to document what is happening in a manner that the dealership will have to acknowledge it.
11-04-2012 11:24 AM
Raceredrudy
Help !! Weird thing happened last night

Hey guys I was driving my 2012 sel hatch and just drove less then a mile to the grocery store , parked , and when I started up I had a CEL ... then the car was driving very odd ... It felt like the gears were all wacky .. I drove less then a minute and pulled into a gas station and cut her off and started back up ... The cel was still on but the gears weren't slipping and the car drove normal for the half mile back to my house ...

Just woke up so I haven't gotten in her yet , but I do remember this happening one time before (gears slipping , car driving wacky) and it went away after I stopped/started again ...

She's an auto sel hatch 12000 miles ... anyone know what could be up?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:07 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat