Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus First Generation > DURATEC Performance (2003-2007) > Engine mounts

DURATEC Performance (2003-2007) The place to chat about any Duratec 23, 23E, and 20 engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
FocusFest

Thread: Engine mounts Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Pitch Black ZX3
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-19-2015 09:51 PM
felixthecat
Quote:
Originally Posted by Spinal View Post
My car never shook when it was stock, now at idle especially when cold with that CFM Dogbone mount it'll shake like crazy till its worked in lol. Sometimes annoying but eh the significant decrease in wheel hop was worth it.
A dogbone as you noticed is well worth the slight vibes,,,,,,
12-19-2015 01:17 PM
Spinal My car never shook when it was stock, now at idle especially when cold with that CFM Dogbone mount it'll shake like crazy till its worked in lol. Sometimes annoying but eh the significant decrease in wheel hop was worth it.
12-18-2015 02:09 PM
M4D5W4GG3R My car had the "shakes." Ton of vibration in the steering wheel at idle. Quick swap of the passenger side mount for me and it went away. Only thing that shakes now is everything because of my subs lol
12-10-2015 07:59 AM
felixthecat Say Stephen, Hows your psm after you've had it for a while?
12-10-2015 07:51 AM
rambleon84
Quote:
Originally Posted by sailor View Post
Jumping into an old thread without details, what car - what mounts - anything checked/replaced?

Is it old & stock, or with some aftermarket as most recently discussed in this one?


Mostly likely blown mounts that need replaced (passenger side or lower trans mount most likely) else someone replaced all factory rubber with poly mounts.
12-09-2015 11:21 PM
sailor Jumping into an old thread without details, what car - what mounts - anything checked/replaced?

Is it old & stock, or with some aftermarket as most recently discussed in this one?
12-09-2015 10:40 PM
christopher.boyd Mine vibes like crazy during acceleration. Vibes the overhead console doors. Wish I knew why.

Sent from my LG-LS980 using FF Mobile
10-26-2015 09:14 PM
felixthecat
Quote:
Originally Posted by 313dtm View Post
That vibration happens to me too. When I turn on the A/C , the steering wheel shakes like crazy.
It is going to vibrate as its connected directly, meaning no rag joints & that makes the steering more responsive.
10-26-2015 07:44 PM
313dtm That vibration happens to me too. When I turn on the A/C , the steering wheel shakes like crazy.
11-08-2012 06:06 AM
felixthecat
Quote:
Originally Posted by karmakc View Post
Hey Felix,
I got the CFM dogbone about a year ago...and I've noticed a few things.

The vibration at around 800-900 rpms is normal for the dogbone, I get that. However, with the A/C on I get a lot of vibration at lower engine speeds too...I never torqued the bolt but did a wrench twist and tightened it up without overloading it...

Any suggestions?
I'd tighten the to bolts to 35lbs. W/ the a/c on your going to have the fans kick on, maybe thats your vibration.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:24 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.




 

Search Engine Optimization by vBSEO 3.6.1