Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus SVT > Focus SVT > '07 ST charging light wont extinquish

Focus SVT The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the MK1 2002-2004 Focus SVT.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: '07 ST charging light wont extinquish Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-18-2012 07:25 PM
Chris_HT i remember I tried to google around for this problem but didn't find anything worth mentioning - glad you got this solved.
09-18-2012 05:04 PM
4flattires Case closed.

I drove for about 30 days with the charge light on and the system charging at normal rate, not really wanting to head to the dealer.

Eventually the new volt regulator failed. A replacement new regulator fully extinguishes the charge light now. 3 weeks and no further issue.
08-07-2012 04:01 PM
4flattires My bad on the title, thinking of another family vehicle. No engine swap, all stock 2007 ST 2.3l.
08-07-2012 03:11 PM
Chris_HT Did you really swap engine for SVT zetec? And if yes, do you experience this issues since the swap?
08-07-2012 02:14 PM
4flattires
'07 ST charging light wont extinquish

Hi all, looking for qualified help here. The application is noted in the title.

The background was a bad regulator, where one brush was sticking. I've replaced the VR and had new slip rings installed. Alternator puts out 14.1 volts (bench test and on-vehicle) and there are no "charging" issues now.

The charge light will illuminate as normal with the key on/engine not running. It stays UNLIT for 23 seconds, then...without fail after 23 seconds...every run cycle the light will then LIGHT UP for the duration of the engine run cycle.

Belt is fine, grounds are no issue, battery fully checks out (load/proper group size/CCA's). I have all this test equipment (DVOM, carbon pile load tester), and it seems the next step is the dealer for install their scan tool. I'd like to avoid this charge. All wiring is in order, solid connections/connectors.

I've narrowed this down to Charging System Diagnostic, Pinpoint Test D, section 414-00-12

Insightful responses would be appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:44 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat