Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Third Generation > MK3 TSB, Recall & Problems Archive > DCT / PowerShift Transmission Update TSB Thread

MK3 TSB, Recall & Problems Archive The place to chat about TSB and Known Issues for the 2012 Focus.

Search This Forum | Image Search | Advanced Search    
FocusFanatics Merchandise

Thread: DCT / PowerShift Transmission Update TSB Thread Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-21-2015 09:44 PM
TKG26
Quote:
- Occasionally when merging onto the highway, the vehicle will go into neutral (simulates fully depressed clutch and full throttle). I have to let go of the pedal for a few seconds and back on to then accelerate normally
I get this when i hammer it to pass cars on the highway... Scares my wife when she hears the thing scream but we are not going faster...
01-21-2015 09:05 PM
evoamac So the dealership didn't want to do it. I called Ford Manufacture Customer Relation department, and they talked to the dealer, and they replaced my clutch asy, as well as cylinder asy. just got the car back, super smooth now. don't know how long it's gonna last though. Because on the receipt it didn't say anything about replace the input shaft seal. I don't know if it is include in the Asy kit.
01-21-2015 02:10 PM
FordService
Quote:
Originally Posted by boombots View Post
As of now the dealer is waiting on the clutch kit which is on backorder
Thanks for getting back to me. Please send me a private message with your VIN, updated mileage, best daytime phone, full name, and dealer name/location. I'll look into this further.

Quote:
Originally Posted by evoamac View Post
brought my car in today, leak tranny fluid, bad shudder sound, jerks like crazy when clutchs hot. And the service guy at the front told me they will take a look at the car, but also said the current fix doesn't really fix the problem. They kept the car today, I have no idea what they are going to do. Are they telling me the truth? The tranny jerks so bad, sometime it wouldn't shift right in the middle of a intersection, which is a serious safety issue now. I don't know what to do.
Have you heard back from your dealer since this post? Please let me know, along with your mileage. I want to look into some additional assistance.

Quote:
Originally Posted by Cubedtothex View Post
...I sent a PM to Meagan here as well...
Got it!

Quote:
Originally Posted by ellisd View Post
Just brought my wife's 2012 Ti in today. Had to get some warranty work done before the 3 years were up so I just mentioned the shuddering as I always do just so there is a record.

Anyway, this morning it was driving actually quite well even though the previous two days when my wife has been driving it was particularily bad. Anyway, mention it to the girl, she said theyw il look at it. I wasn't expecting much but she called back saying they need to order parts in so I can come pick it up for now and they will call when they are in.

After hearing all the horror stories of people's dealerships here, it's nice to get some decent response from the one I go to (Metro Ford Calgary).

Anywho, I'll update here to see what rev I get.
Glad to hear things are going well. If you need me, I'll be here.

Meagan
01-21-2015 02:05 PM
ellisd Just brought my wife's 2012 Ti in today. Had to get some warranty work done before the 3 years were up so I just mentioned the shuddering as I always do just so there is a record.

Anyway, this morning it was driving actually quite well even though the previous two days when my wife has been driving it was particularily bad. Anyway, mention it to the girl, she said theyw il look at it. I wasn't expecting much but she called back saying they need to order parts in so I can come pick it up for now and they will call when they are in.

After hearing all the horror stories of people's dealerships here, it's nice to get some decent response from the one I go to (Metro Ford Calgary).

Anywho, I'll update here to see what rev I get.
01-20-2015 10:10 PM
sailor
Quote:
Originally Posted by evoamac View Post
brought my car in today, leak tranny fluid, bad shudder sound, jerks like crazy when clutchs hot. And the service guy at the front told me they will take a look at the car, but also said the current fix doesn't really fix the problem. They kept the car today, I have no idea what they are going to do. Are they telling me the truth? The tranny jerks so bad, sometime it wouldn't shift right in the middle of a intersection, which is a serious safety issue now. I don't know what to do.
And they've got that guy on a front desk?

Seal replacement with a newer design, and the same for the clutch pack is std. for a start - and the better Dealerships look for anything else that might be troublesome while they're in there.

Got a better Dealership in the area by chance?
01-20-2015 01:51 PM
Cubedtothex Just called my service advisor today since I didn't hear anything. I was told that the parts are on order due to my clutches....surprise surprise. I'm happy the threshold that was needed during testing was hit! So I'll pick it back up tonight and hope I survive until the parts are in. Although following up isn't up to par, I've been treated right in every other aspect.
01-19-2015 09:06 PM
Cubedtothex Quick update. After I got my rental, I had to stop by and pick up my parking pass for work. I was able to ask the advisor about the computer scanner malfunction and she said the dealership only has two and the other one was being used at the same time this afternoon.

Right before I left she said something that tipped me off that she was aware of something as she said there may be an issue with the clutches and asked if it occurs more when it's been running hot. The funny thing is I did a little bit of driving before arriving to see if I could hear it up in order for it to be more prominent. I told her that I take the highway to work and back and when it's had time to warm up, it does act up a bit more after I've arrived to work and hunt for parking. She said she will make sure the techs are doing their test when it's hot, not cold. She also mentioned the extended warranty several times. She's had this come up before.

I also have a close friend who has a 2012 or 2013 SEL sedan that has had multiple issues and actually warned me about it. I let him know I was very aware of the issues other have been experiencing. He told me to bring my car in ASAP, but this was before I was having any trouble. I didn't want to bring it in unless I knew I was experiencing the signs....which I now have about a year later.
01-19-2015 06:58 PM
JM1984 The Service Manager at my dealer said that it drives best when you hold the accelerator constant through all 6 gears. This probably won't solve your problem, but it's easier to describe your problem to the dealer if you have a "routine."

Sorry, I was replying to HeisGreater330 and forgot to quote the message.
01-19-2015 04:45 PM
Cubedtothex I guess it's now my turn. I figured I would address it since I brought it in for an oil change and tire rotation today. I can no longer live in denial as I've experienced the following:

- Feeling of losing traction when accelerating from a stop, but without wheelspin. It's a feeling similar to losing traction on rails

- When lightly accelerating from a stop, barely pushing the pedal the vehicle will occasionally perform like too much gas was applied and a popped out clutch happens, causing undesired wheelspin

- Occasionally when merging onto the highway, the vehicle will go into neutral (simulates fully depressed clutch and full throttle). I have to let go of the pedal for a few seconds and back on to then accelerate normally

- Occasionally when accelerating from a stop, vehicle will initially move forward then simulates a sudden loss of power for a second, then continues to accelerate, all while not changing my foot on the pedal

- When attempting to accelerate, the vehicle will occasionally hold revs in 2nd or 3rd gear and just hang, before fully engaging the gear


I brought it in at 7 am, for some reason, they didn't hook my car up to the computer until this afternoon and something went wrong with the system they were using, The service advisor told me it would have to come back at 9 am tomorrow! I found this to be a bit ridiculous and asked for a rental as this isn't my problem and I made my appointment a week ago. Obviously they wouldn't hook it up to the computer if they couldn't sense anything with a test drive so I know something is of concern to them. Seems like they are treating me right here, so I may be inclined to purchase from this dealer in the future, just not something with this type of transmission!

I basically gave the service advisor in writing what I have been experiencing, including the fact of how familiar I am with this type of transmission and that I had a 2007 5 speed manual. This way we can skip the "do you know" part of the conversation.

I sent a PM to Meagan here as well.

I'm waiting for a call from the dealer to say my rental is ready and pick up something out of my own vehicle on the way.

To be continued...
01-19-2015 04:12 PM
evoamac
Quote:
Originally Posted by evoamac View Post
brought my car in today, leak tranny fluid, bad shudder sound, jerks like crazy when clutchs hot. And the service guy at the front told me they will take a look at the car, but also said the current fix doesn't really fix the problem. They kept the car today, I have no idea what they are going to do. Are they telling me the truth? The tranny jerks so bad, sometime it wouldn't shift right in the middle of a intersection, which is a serious safety issue now. I don't know what to do.
This is a pic I took yesterday on the leak.

This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:55 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat