Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Racing Discussions > Autocross Racing > New to the forums, first autocross! help!

Autocross Racing The place to discuss information about autocross stats, tips and events. Track sanctioned events only.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: New to the forums, first autocross! help! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-24-2012 01:15 AM
tukaniSVT Yeah, my first tranny had some chatter noise, then when I got it replaced with another OEM one, I haven't really heard it since. I changed it at 126K when it blew and I am now at 168K ... still running strong through all of my hard pushing in AutoX.

I dont know about confusing 1st with Reverse. Pretty hard to do since their is a gate that you have to put some force on to get it into Reverse.

I do agree that you have to learn how the gears are made in the slots, because it does take a bit of time to get use to as any manual tranny. I also had a hard time doing quick shifts with my first go around with the focus.

But in AutoX, you really don't need to shift that fast, it's really more about timing and when to shift into 2nd.

-Ray-
04-24-2012 12:49 AM
ViperThreat Beginners mistake with the SVT when shifting hard is to confuse reverse with 1st gear. First time I tracked my car, I downshifted from third to second, and couldnt get in.. Turned out i was just pushing a bit to hard to the left. That could be it.

As for the chatter, thats a stock clutch thing, I thought they took care of that with the newer clutches, but maybe they didnt. Most guys I know with the OE clutches dont have the problem anymore.
04-23-2012 10:39 PM
DrivenSVT Thanks for the link. I'm planning to stay H stock. Carl @ Massive will be hooking me up with Koni's. Yes, the mounts r mushy and the shifter rattles like a mofo in first gear. I got the car for a good price so I shouldn't be too surprised to put a few bucks in it. Clutch was done last september and it shows synthetic fluid on the receipt.

How about the chatter? TB chatters when disengaged but goes away with a tap of the pedal. Is this a dual mass trait?

The motor ticks a bit once warm. Is this normal? It doesn't seem to effect much but seemed louder in LH sweepers. Oil level is spot on.
04-23-2012 10:21 PM
tukaniSVT Also, keep it as stock as possible, the SVTF is a great contender in H-Stock.

-Ray-
04-23-2012 10:20 PM
tukaniSVT First off, to the forum.

Yes the part is replaceable. I believe CFM has it. CLICKY HERE FOR LINK.

Have you changed the Tranny fluid in the SVT since you picked it up? That will also help with a better smooth transition on shifts.

Also, have you checked the Lower Motor mount, is it still stiff or mushy? That will effect the motor moving from the tranny a bit, be surprised how that little bit of movement can effect you in AutoX.

Congrats on the SVTF, and good luck and enjoy AutoX. We all here, fully enjoy it.

-Ray-
04-23-2012 08:20 PM
DrivenSVT
New to the forums, first autocross! help!

I have a couple friends to autocross their Foci and talked me into buying one as a daily driver. I picked up in 03 SVT 5door with 140k. After replacing three wheels two wheel bearings and tires, It seems to be good. I took it out for its first autocross this weekend. What a blast to drive! This thing is great but I have one issue so far. A couple of the runs I couldn't find second gear, it just didn't exist. I wound up shifting to third and then back to second but it didn't work each time. For DD duty, it works fine.

I noticed an insert on the shifter at the trans that looks like it's broken or missing a chunI. Kind of a rectangular teflon insert. Is this a replaceable/available part?

Next AX is on the 19th and I'd like to fix it before then.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:51 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Cadillac ATS-V, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.