Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Forced Induction > Its a gusher!!

General Forced Induction The place to chat about turbochargers, superchargers nitrous systems and custom engine fabrications.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Its a gusher!! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-08-2012 09:30 AM
sporadic Turbo just needs rebuilt. I've been through this except mine pumped most of the oil out the turbine side and smoked like crazy.
03-07-2012 09:23 PM
svtf1417
Quote:
Originally Posted by zx3ss View Post
needs a catch can
Im in the process of removing the stock PCV baffle that Im almost positive is plugged up/blocked, or a combination of the two that isnt letting the crankcase pressure out like it should. Ive got leaks coming from EVERYWHERE thats another reason I think its plugged up. Im talking oil pan, lower crank case gasket, valve cover gasket, front main seal. oil has even soaked the filter I put on the valve cover vent. All of these gaskets are brand new. I could see one maybe 2 gaskets not being right or defective out of the box, but ALL of them cant. The last time I saw something like that, was when my friend built his own motor and didnt have a PCV system, so I think I have the same problem.

Still doesnt explain the massive amount of oil in the charge piping ha
03-07-2012 08:21 PM
FLYLOW needs a catch can
03-07-2012 07:53 PM
ZXthrizzle05 im suprised it has ran well with an improper tune. my car before it bllits gasket ran spotty so to say for bout a year and kept blowing o2 sensors like crazy turns out the oil pressure sensor was cut at the wires and the knock sensor had been cut or pulled out as well. when i did my rebuild i looked at the back of the block andd like WTF IS THIS NO WONDER!!!!!!!!!!!!!!!
03-07-2012 06:51 PM
svtf1417 Im 98% sure I havnt had that pipe on since I put the turbo on the car. That was in last june/july. I put somewhere in the vicinity of 3500 miles on the car. It has idled and been driven around for tuning purposes on top of that. I dont know, seems a little excessive to me. I plan on pulling the turbo off the rest of the way tonight and see if the inlet is clean, if theres any oil in the downpipe, and if it has any shaft play.

BTW, Ive never had a full tune on the car thanks the SCT's failing xcal and winter
03-07-2012 01:14 PM
iroc34 How long was it since the last time you had the pipes off ? Here is my motto. If it isnt broke , dont fix it. If it`s not smoking, and building boost the way it`s supposed to I wouldnt worry to much. Keep an eye on it now that you know it is leaking. And see how much oil gets by in a couple days maybe even a week.
What`s strange to me is , how we get used to the way our cars run, and dont really notice the performance falling off, if its a little at a time. Then when you give it a tune up or repair a small problem and the car comes alive again. You go , crap ! it was running bad.
03-07-2012 01:32 AM
bringler26 Your floor looks as bad as the time I missed the drain pain
03-06-2012 10:42 PM
1turbofocus The seals are metal and in some cases ceramic

Tom
03-06-2012 09:20 PM
ZXthrizzle05 daaaaaaaaaaaaaaaaaaaamn look at that oil
03-06-2012 09:05 PM
svtf1417 probably alot more then I was led to believe. Im guessing the seals are blown and Im pretty sure theyre just high temp rubber o-rings arent they?
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:35 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Cadillac ATS-V, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.