Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Racing Discussions > Drag Racing > Drag Help Needed

Drag Racing The place to discuss information about drag racing stats, tips and events. Track sanctioned events only.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Drag Help Needed Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-25-2008 07:29 AM
SVTF200487 yep all the mounts are stock. I haven't been able to afford a new dogbone mount. But that is at the top of my list to buy.
05-25-2008 12:02 AM
goinloco1 what motor mounts are you using?
during the vid i could hear the rear one slapping, once that starts it'll cause hop.
a good aftermarket mount or all mounts would help alot. the banging sounds like your running the stock mount.
05-24-2008 06:02 AM
SVTF200487
Drag Help Needed

I finally got some video of my Drag racing at the strip. I was launching at 3500-3800k with my traction control fuse pulled. My tires are Nexen N3000 with about 35% tread left on them. I was running them with 28psi in them. If yall need to know I weigh about 275 and my pass. weighs about 160. All these runs are at best a 10.3 1/8 mile time. If yall could give me some hints on how to do better I would be thankful. I know with what all I have done to the car it will run better times.

When I had bogging issues:


When I had wheel hop issues:


This is the run I had clutch issues:


Here is one run where I ran a buddy's fox. He runs consistant 9.1-9.3 time:


Yes I do know it is about time for a clutch. It only acted up in that second run. And here is just another video I uploaded. (when I had my car dynoed they found the siren)


Thanks for all the help in advance.
Mike

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:05 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat