Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus First Generation > SPI Performance (2000-2004) > PCV Valve on teh SPI.. - finally found it.

SPI Performance (2000-2004) The place to chat about any 2.0L Split Port Injection engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: PCV Valve on teh SPI.. - finally found it. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-17-2004 09:35 PM
Code415
Quote:
Originally posted by waterboy
Did that solve your problem? Just wondering. Mine idles kinda rough. Could be the bigger injectors or the solid motor mount though. Just wondering if it made a difference.

Jim
I dont think either you or myself will ever see a normal idle. Mine is set at almost 900rpms and it still rattles. I think imma set it for 1000-1100.
06-17-2004 09:06 PM
waterboy Did that solve your problem? Just wondering. Mine idles kinda rough. Could be the bigger injectors or the solid motor mount though. Just wondering if it made a difference.

Jim
06-17-2004 06:10 PM
The_good_guy
PCV Valve on teh SPI.. - finally found it.

It took a while, but I finally found the PCV valve on the SPI.

If you got to get a new valve, dont go to autozone or pepboys or whatever, they dont have the part on their computers.. I looked.

The motorcraft part number for the SPI is EV-262.
Atleast that is what it was for my 2000 SPI.

Now the stock PCV valve looks different from the motorcraft replacement. The old valve has a nice triangular cover on both sides on the inside (sorta like a shield i would say.. its kinda weird) but the new one is open on the inside. However this is the part and i checked with galpin ford. It might look differnet.. but its the part.

My stock part was working alright (i shook it and it rattles) but i decided to replace the valve just in case - i was trying to track down this weird vibration on my car during idle.. basically a rough idle.

WARNING: Make sure you check your rubber hose that goes from the PCV valve to the Intake.. I have to replace mine - the rubber is worn out and is colapseing when I start the engine.

To find the SPI PCV valve, look on your valve cover. On the left side of the valve cover is a tube, this IS NOT your PCV valve , though you would assume it to be. This runs to the PCV filter / Breather filter inside your stock airbox.

The actual PCV valve is on the top right of the valve cover. If you look at your oil filler hole, go north from there on the valve cover and then go east. You will run into it. It is covered under the other tube that runs from the other side of the valve cover. Basically its on the top right side of your valve cover. You will find it.

To take it off:

1) Detach the PCV hose from the PCV valve. Should be a large hose going to the intake manifold.
2) Rotate the PCV valve counterclockwise.
3) Pull the PCV valve from the valve cover.
4) To install, reverse the removal procedure.

I highly suggest checking that tube that runs from the PCV valve to the intake.. I have to now replace that bloody tube... I just happened to check before installing my PCV valve and noticed that the tube shrinks when i start the engine.. it shouldnt shrink..

Actually check all your tubes.. to make sure nothing is cracked and stuff..

I got 69K on mine, and I just replaced teh PCV valve, i dont know when it was to be replaced, or if it needed replacing, but i went ahead just in case.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:18 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Cadillac ATS-V, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.