Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat > My A/C fuse keeps blowing!

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: My A/C fuse keeps blowing! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-15-2007 04:43 PM
SVTORNG It's fixed! I traced the A/C wires from the A/C compressor and about 5 inches into the loom the wires had kinked. This caused the insulation on both wires to wear. So, the wires were touching causing a short. Problem found and solved! So, check your A/C connections/wires because this looks like a factory made weak spot.
Thanks for all your help!
05-09-2007 12:28 PM
focusfreak03 yeah, it sounds like you have some current leakage and your a/c unit is pulling more than the fuse can handle. check the whole wire, not just the connections, you could have a skinned or burnt wire that is causing the current leak
05-08-2007 09:59 PM
SVTORNG
Quote:
Originally Posted by zx32nr View Post
bad ground????
hhmmmmm? I can do some checking. Perhaps a body ground is lose? Battery Ground? My SVT Focus is bone stock and I've never put a wrench to it...yet.
05-08-2007 09:47 PM
zx32nr bad ground????
05-08-2007 08:33 PM
SVTORNG
My A/C fuse keeps blowing!

Hey all,

I'm new to the site and I'm hoping I can pick your brains.

The 10amp fuse to my A/C keeps blowing! This is the fuse located in the fuse panel under the hood. All the other A/C fuses are fine.

What's the deal? I've never had this issue before. One day the A/C is working like a champ then the fuse blows. Why?

I've replaced the fuse twice now and the A/C will work until I turn off the engine. Once I fire it up again and press the A/C button there's no cold air and the fuse is blown. I truly hope there isn't a serious electrical issue.


Thanks for your help and suggestions!

Jared

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:02 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat