No Power starting or up hill - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Third Generation > MK3 Focus

MK3 Focus The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the third generation 2012-Current Focus.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Reply




 
LinkBack Thread Tools Display Modes
Old 06-11-2012, 07:23 AM   #1
Focus Enthusiast
 
Join Date: Dec 2008
Fan#: 61273
Location: Bridgeville, PA
What I Drive: 2012 Focus Titanium

Posts: 89
FF Reputation: 1 knightp25 Good Standing Member
Buy-Sell-Trade Rating: (0)
No Power starting or up hill

Has anyone esle experienced a lack of power starting from a red light or going up a hill, I push the gas and its like it takes a second or so, for it to get going, unless i really push the gas down hard.


good example i was going up a steep hill, had to slow down to about 5 mph and then i hit the gas to go again and the car seemed like it wanted to bog down and stall, i had to completely stop and then start again to go up the hill.


knightp25 is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-11-2012, 08:05 AM   #2
Focus Enthusiast
 
Join Date: Aug 2011
Fan#: 88463
Location: Haileybury, Canada
What I Drive: 2012 Lincoln MKZ AWD Ingot Silver

Posts: 179
FF Reputation: 2 Blizzard35 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by knightp25 View Post
Has anyone esle experienced a lack of power starting from a red light or going up a hill, I push the gas and its like it takes a second or so, for it to get going, unless i really push the gas down hard.


good example i was going up a steep hill, had to slow down to about 5 mph and then i hit the gas to go again and the car seemed like it wanted to bog down and stall, i had to completely stop and then start again to go up the hill.
Hi...yes I have been complaining about this exact issue for a while and my car has had "every" transmission update/reflash etc. issued. The other thing I have noticed is going up a hill, once I reach the top, the engine continues to over-rev but the power does not seem to be there...I described it to my dealer as being like driving a bicycle and then the chain falls off suddenly! Very frustrating to say the least.
Blizzard35 is offline  
    Reply With Quote Quick reply to this message
Old 06-11-2012, 08:12 AM   #3
Focus Enthusiast
 
jfsiutza's Avatar
 
Join Date: Mar 2012
Fan#: 97007
Location: Albuquerque, NM
What I Drive: 2012 Ford Focus SE Hatch Tuxedo Blk

Posts: 136
Points 1,231, Level 19
Points: 1,231, Level: 19 Points: 1,231, Level: 19 Points: 1,231, Level: 19
Level Up 31% Completed
Level up: 31% Level up: 31% Level up: 31%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 jfsiutza Good Standing Member
Buy-Sell-Trade Rating: (0)
i have a manual transmission and ive been getting the same response on the gas pedal only. sometimes the computer does something and takes away pedal response is what i think. i pushed the gas pedal all the way down it only went to 3000rpm let go and stayed at 1500rpm for about 30seconds.
jfsiutza is offline  
    Reply With Quote Quick reply to this message
Old 06-11-2012, 10:31 AM   #4
Focus Enthusiast
 
Join Date: Dec 2008
Fan#: 61273
Location: Bridgeville, PA
What I Drive: 2012 Focus Titanium

Posts: 89
FF Reputation: 1 knightp25 Good Standing Member
Buy-Sell-Trade Rating: (0)
just glad that im not the only one having the problem.

Was wondering if it was just my car or i wasnt used to the way it drives.
knightp25 is offline  
    Reply With Quote Quick reply to this message
Old 06-11-2012, 01:23 PM   #5
Focus Enthusiast
 
Pretherius's Avatar
 
Join Date: Mar 2012
Fan#: 97062
Location: Columbus, OH
What I Drive: 2012 SE Sedan 5-Spd Sterling Gray

Posts: 512
FF Reputation: 1 Pretherius Good Standing Member
Buy-Sell-Trade Rating: (0)
I have the manual too and I haven't quite experienced this under the same circumstances, but... There are times when I stop the engine if I know I'm going to be sitting in traffic for a long time, and if I restart it and immediately try to take off, it takes a LOT of pedal to get moving quickly. If I let it idle for like 3 seconds before launching then it takes off just fine. I know this isn't exactly the same thing but maybe there's a clue in here somewhere...
Pretherius is offline  
    Reply With Quote Quick reply to this message
Old 06-11-2012, 01:34 PM   #6
Focus Fanatic
 
Join Date: Jul 2011
Fan#: 88299
Location: Torrance, CA
What I Drive: 2012 sterling gray Titanium

Posts: 3,483
Points 4,888, Level 44
Points: 4,888, Level: 44 Points: 4,888, Level: 44 Points: 4,888, Level: 44
Level Up 69% Completed
Level up: 69% Level up: 69% Level up: 69%
Forum Activity 8%
Activity: 8% Activity: 8% Activity: 8%
FF Reputation: 11 Kabigon Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by knightp25 View Post
just glad that im not the only one having the problem.

Was wondering if it was just my car or i wasnt used to the way it drives.
Does your car have the latest updates?
Kabigon is offline  
    Reply With Quote Quick reply to this message
Old 06-11-2012, 01:36 PM   #7
Focus Fanatic
 
nov173's Avatar
 
Join Date: Nov 2005
Fan#: 29840
Location: Pittsburgh, Pa, United States
What I Drive: 2014 Focus ST

Posts: 3,263
FF Reputation: 79 nov173 Excellent Standing Member
Buy-Sell-Trade Rating: (4)
ya it's just the car man...
__________________
SVT header kit, 2.25 MBRP cat-back & flex, r/t high flow cat. aem cai, frpp kit

For Sale: Rear bumper(stock). SVT side skirts FS as well. Buy em!!!!
nov173 is offline  
    Reply With Quote Quick reply to this message
Old 06-11-2012, 01:43 PM   #8
Focus Addict
 
Join Date: Apr 2012
Fan#: 98064
Location: San Diego, CA
What I Drive: 2010 BMW 128i; 2012 Focus SE Sport

Posts: 570
FF Reputation: 3 Bimmer-Bob Good Standing Member
Buy-Sell-Trade Rating: (0)
I have a car that was built 5/29 so should have all the updates. I find it to be really gutless off the line sometimes. Notably on rolling stops I often have to shift all the way down to 1st whereas in most other cars I've experienced there is enough torque to take off from 2nd. If I do try to take off in 2nd it really bogs. I guess it's just a matter of learning this drivetrain, although I've driven other economy cars without this issue.
Posted via FF Mobile
Bimmer-Bob is offline  
    Reply With Quote Quick reply to this message
Old 06-11-2012, 02:32 PM   #9
Focus Rookie
 
Join Date: Apr 2012
Fan#: 97982
Location: Toronto, Canada
What I Drive: 2012 Focus Titanium - Sterling Grey

Posts: 2
FF Reputation: 1 RabidDriver Good Standing Member
Buy-Sell-Trade Rating: (0)
I have the automatic and the update did nothing to change the hesitation in acceleration. I just popped a K&N filter into her a couple days ago though and that got rid of the hesitation. I recommend you make that $50 upgrade.
(Just the drop in filter - Not a CAI or anything)

Edit: I did my update March 31st. Service bulletin 12-1-4? So i'm not sure if there is another update that changes the shifting power bands. But like I said the new filter definitely helped.
RabidDriver is offline  
    Reply With Quote Quick reply to this message
Old 06-11-2012, 02:51 PM   #10
Focus Enthusiast
 
Join Date: Dec 2008
Fan#: 61273
Location: Bridgeville, PA
What I Drive: 2012 Focus Titanium

Posts: 89
FF Reputation: 1 knightp25 Good Standing Member
Buy-Sell-Trade Rating: (0)
off the line is horrible, maybe its the gearing causing the slow responseness.

i thought i read somewhere about having a double clutch system
knightp25 is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:39 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1