Electrical gremlins inside.. Timing belt change related? Needs to be fixed yesterday - Page 2 - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Reply




 
LinkBack Thread Tools Display Modes
Old 04-18-2014, 08:31 PM   #11
Focus Enthusiast
 
smallblockfever's Avatar
 
Join Date: Feb 2012
Fan#: 95004
Location: Baton Rouge, LA
What I Drive: 2002 Sonic Blue SVT

Posts: 223
Points 2,372, Level 29
Points: 2,372, Level: 29 Points: 2,372, Level: 29 Points: 2,372, Level: 29
Level Up 48% Completed
Level up: 48% Level up: 48% Level up: 48%
Forum Activity 4%
Activity: 4% Activity: 4% Activity: 4%
FF Reputation: 0 smallblockfever Newbie
Buy-Sell-Trade Rating: (1)
BOOYAH
It looks like it was the driver side ground for that section of the wiring harness. I didn't touch it recently, so I can't imagine how it would have affected things at all

all I did was grind away all the paint on the grounding spot, grind away surface build up on the terminal, wire brushed the bolt, did the same for my battery to chassis ground, and made sure those two grounds were not grounded to the same bolt. Then I topped it all off with some dielectric grease.

Once again, I'm super stoked to have some awesome knowledge out there on the forum with you guys

Can someone explain to me why my ground would have all of a sudden not been sufficient? It worked just like that for almost a month. The only thing that changed was I did the timing belt change. thoughts?
__________________
"Never miss a good chance to shut up."
smallblockfever is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-18-2014, 08:53 PM   #12
Focus Enthusiast
 
Bills86e's Avatar
 
Join Date: Sep 2013
Fan#: 119322
Location: pinellas park, FL
What I Drive: 2000 green SE, 2007 Kappa Speedster

Posts: 214
Points 398, Level 7
Points: 398, Level: 7 Points: 398, Level: 7 Points: 398, Level: 7
Level Up 96% Completed
Level up: 96% Level up: 96% Level up: 96%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 Bills86e Good Standing Member
Buy-Sell-Trade Rating: (0)
Same reason, Snit happens. Some times paint under the ground "right from the factory".
Ya still gotta have good metal to metal as grounds are everything, ya did real good!
Bills86e is offline  
    Reply With Quote Quick reply to this message
Old 04-18-2014, 08:53 PM   #13
Hammer Down
 
sailor's Avatar
 
Join Date: Jun 2008
Fan#: 57268
Location: Williamsville, NY
What I Drive: 2004 Pitch Black ZTS 2.3 5spd.

Posts: 19,554
Points 13,927, Level 76
Points: 13,927, Level: 76 Points: 13,927, Level: 76 Points: 13,927, Level: 76
Level Up 70% Completed
Level up: 70% Level up: 70% Level up: 70%
Forum Activity 100%
Activity: 100% Activity: 100% Activity: 100%
FF Reputation: 82 sailor Excellent Standing Member
Buy-Sell-Trade Rating: (0)
Just good enough 'till the day it isn't, then it's no good at all. Might test to have continuity with a meter, but won't handle a load in the condition it reached when it quit.

Glad it's working!
__________________
"Rubber Side Down"

S.R. #275 Focus Takeover #003
sailor is online now  
    Reply With Quote Quick reply to this message
Old 04-18-2014, 11:44 PM   #14
Focus Enthusiast
 
smallblockfever's Avatar
 
Join Date: Feb 2012
Fan#: 95004
Location: Baton Rouge, LA
What I Drive: 2002 Sonic Blue SVT

Posts: 223
Points 2,372, Level 29
Points: 2,372, Level: 29 Points: 2,372, Level: 29 Points: 2,372, Level: 29
Level Up 48% Completed
Level up: 48% Level up: 48% Level up: 48%
Forum Activity 4%
Activity: 4% Activity: 4% Activity: 4%
FF Reputation: 0 smallblockfever Newbie
Buy-Sell-Trade Rating: (1)
Yea it was definitely testing as a good ground on the meter, but i guess it's like you said, it wasn't enough! Looks like I shall be doing the big 3 sooner rather than later.
__________________
"Never miss a good chance to shut up."
smallblockfever is offline  
    Reply With Quote Quick reply to this message
Old 04-19-2014, 11:05 AM   #15
Hammer Down
 
sailor's Avatar
 
Join Date: Jun 2008
Fan#: 57268
Location: Williamsville, NY
What I Drive: 2004 Pitch Black ZTS 2.3 5spd.

Posts: 19,554
Points 13,927, Level 76
Points: 13,927, Level: 76 Points: 13,927, Level: 76 Points: 13,927, Level: 76
Level Up 70% Completed
Level up: 70% Level up: 70% Level up: 70%
Forum Activity 100%
Activity: 100% Activity: 100% Activity: 100%
FF Reputation: 82 sailor Excellent Standing Member
Buy-Sell-Trade Rating: (0)
Test light is better proof for power, since it takes at least a little to light it. I've got a powered test light that can check power or ground, I THINK it's a little better for testing marginal grounds than a meter for the same reason.

All to easy to be fooled by a marginal connection that's only good enough to look OK to a tester - not good enough to handle a load.
__________________
"Rubber Side Down"

S.R. #275 Focus Takeover #003
sailor is online now  
    Reply With Quote Quick reply to this message
Old 04-20-2014, 10:16 PM   #16
Focus Rookie
 
Join Date: Jul 2011
Fan#: 87510
Location: Denver, CO
What I Drive: 2003 Competion Orange SVT

Posts: 12
Points 162, Level 3
Points: 162, Level: 3 Points: 162, Level: 3 Points: 162, Level: 3
Level Up 24% Completed
Level up: 24% Level up: 24% Level up: 24%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 Rock36 Good Standing Member
Buy-Sell-Trade Rating: (0)
Same problem...Kinda

I am having the same problem but on the passenger side. My lowbeam, tail light and side marker lights don't work and keep blowing fuses. Does anybody know where the passenger side ground is? Thanks! CM
Rock36 is offline  
    Reply With Quote Quick reply to this message
Old 04-20-2014, 11:09 PM   #17
Focus Fanatic
 
Marde's Avatar
 
Join Date: Jun 2013
Fan#: 115991
Location: Mesa, AZ
What I Drive: 2004 ZTW PZEV 2.3 ATX

Posts: 1,577
Points 1,924, Level 26
Points: 1,924, Level: 26 Points: 1,924, Level: 26 Points: 1,924, Level: 26
Level Up 24% Completed
Level up: 24% Level up: 24% Level up: 24%
Forum Activity 35%
Activity: 35% Activity: 35% Activity: 35%
FF Reputation: 13 Marde Great Standing Member
Buy-Sell-Trade Rating: (0)
A bad electrical ground that causes a fuse to blow is rare, but can happen. More likely that you have a broken/damaged hot wire touching ground somewhere on that side. Please inspect all light bulb holders/sockets and inspect the surrounding wiring area too.

Also consider door/hatch wiring (rubber boots) that get moved when a door opens.

damaged wires pic here;
Trunk release does not work even with new release
__________________
You've got to ask yourself one question: Do you feel lucky? -and could you really drive a Focus ATX Wagon?
Marde is online now  
    Reply With Quote Quick reply to this message
Old 04-21-2014, 08:52 AM   #18
Focus Enthusiast
 
smallblockfever's Avatar
 
Join Date: Feb 2012
Fan#: 95004
Location: Baton Rouge, LA
What I Drive: 2002 Sonic Blue SVT

Posts: 223
Points 2,372, Level 29
Points: 2,372, Level: 29 Points: 2,372, Level: 29 Points: 2,372, Level: 29
Level Up 48% Completed
Level up: 48% Level up: 48% Level up: 48%
Forum Activity 4%
Activity: 4% Activity: 4% Activity: 4%
FF Reputation: 0 smallblockfever Newbie
Buy-Sell-Trade Rating: (1)
Quote:
Originally Posted by Rock36 View Post
I am having the same problem but on the passenger side. My lowbeam, tail light and side marker lights don't work and keep blowing fuses. Does anybody know where the passenger side ground is? Thanks! CM





if you look where the headlight connector is, the ground exits the wiring harness within a few inches and then extends towards the rear of the car for about 4-6" before bolting down.



If in doubt, the ground is very close to the passenger motor mount.
__________________
"Never miss a good chance to shut up."
smallblockfever is offline  
    Reply With Quote Quick reply to this message
Old 04-21-2014, 08:53 AM   #19
Focus Enthusiast
 
smallblockfever's Avatar
 
Join Date: Feb 2012
Fan#: 95004
Location: Baton Rouge, LA
What I Drive: 2002 Sonic Blue SVT

Posts: 223
Points 2,372, Level 29
Points: 2,372, Level: 29 Points: 2,372, Level: 29 Points: 2,372, Level: 29
Level Up 48% Completed
Level up: 48% Level up: 48% Level up: 48%
Forum Activity 4%
Activity: 4% Activity: 4% Activity: 4%
FF Reputation: 0 smallblockfever Newbie
Buy-Sell-Trade Rating: (1)
Well Marde, considering that my reverse lights seldom work and my reverse lights in general have lost all of their grommets that seal it to the body, I think I'll be tackling that one next
__________________
"Never miss a good chance to shut up."
smallblockfever is offline  
    Reply With Quote Quick reply to this message
Old 04-22-2014, 05:40 AM   #20
Focus Rookie
 
Join Date: Jul 2011
Fan#: 87510
Location: Denver, CO
What I Drive: 2003 Competion Orange SVT

Posts: 12
Points 162, Level 3
Points: 162, Level: 3 Points: 162, Level: 3 Points: 162, Level: 3
Level Up 24% Completed
Level up: 24% Level up: 24% Level up: 24%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 Rock36 Good Standing Member
Buy-Sell-Trade Rating: (0)
Thanks guys! I'll have a look this weekend and report back!
Rock36 is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 11:31 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1