2004 SVT ignition - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Reply
 
LinkBack Thread Tools Display Modes
Old 07-01-2013, 09:34 AM   #1
Focus Rookie
 
Join Date: May 2013
Fan#: 114988
Location: Salt Lake City, United States
What I Drive: WTB 2004 SVT EAP

Posts: 13
FF Reputation: 1 Bexfocus Good Standing Member
Buy-Sell-Trade Rating: (0)
2004 SVT ignition

Hello everyone.

I recently purchased a 2004 SVT Focus with 63000 miles. I flew into Chicago from Salt Lake City and drove it back. It ran great about 500 miles into my trip back, I lost all power. I pulled over and noticed that the plug that enters the front of the MSD ignition had come out. I plugged it back in, and started driving again. Almost instantly the car lost power and check engine light came on. Same thing, that front plug had come out again. I wrapped some electrical tape around it to keep the plug in. Unfortunately, I didn't have a code reader. I cleared the code and it has not come back on. The car is now REALLY sluggish until about 3500 RPM. I have to give it a LOT of gas to get the car moving in first, like rev to 3000. When it hits 5000 RPM, all the top end power is there, there is just no power down low. No codes still. What should I check first? I bought some new plugs, so I will have more info when I pull them. Could having that plug pop out damage the ignition? Thanks.

Brian


Bexfocus is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-02-2013, 02:09 AM   #2
Focus Enthusiast
 
F O C U S's Avatar
 
Join Date: Oct 2010
Fan#: 79747
Location: Pleasantville, NJ
What I Drive: 2003 SVT

Posts: 100
Points 621, Level 12
Points: 621, Level: 12 Points: 621, Level: 12 Points: 621, Level: 12
Level Up 43% Completed
Level up: 43% Level up: 43% Level up: 43%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 F O C U S Good Standing Member
Buy-Sell-Trade Rating: (0)
Are you talking about the pigtails?
I had a problem with mine car it ran real sluggish. I didn't have any codes, when i checked the pigtail wiring it was pretty screwed I Bought some at Ford and my problem went away.

__________________
2003 Ford Focus SVT #1091
F O C U S is offline  
    Reply With Quote Quick reply to this message
Old 07-02-2013, 02:25 AM   #3
FF's Night Security
 
sleepyboy's Avatar
 
Join Date: Nov 2004
Fan#: 15335
Location: SW Houston, TX, United States
What I Drive: 01' Yellow ZX3 euro, 04' ZX5 SVT

Posts: 27,614
Points 147,936, Level 100
Points: 147,936, Level: 100 Points: 147,936, Level: 100 Points: 147,936, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 88%
Activity: 88% Activity: 88% Activity: 88%
FF Reputation: 51 sleepyboy Excellent Standing Member
Buy-Sell-Trade Rating: (11)
Moved to the Technical Chat area


The part F O C U S posted is what you want to get. You can get them at the dealer and I even think you can get them elsewhere now as well like Rockauto.
__________________
I started out with nothing and I still have most of it left

Hatch Nation #15 (Ole' Yeller') & #150 (The SVT)
Moderator for
Technical Chat
Zetec Performance Chat
Southern Fanatics Chat
sleepyboy is online now  
    Reply With Quote Quick reply to this message
Old 07-02-2013, 08:03 AM   #4
Focus Rookie
 
Join Date: May 2013
Fan#: 114988
Location: Salt Lake City, United States
What I Drive: WTB 2004 SVT EAP

Posts: 13
FF Reputation: 1 Bexfocus Good Standing Member
Buy-Sell-Trade Rating: (0)
That is the plug that popped off twice. I must have damaged it the 2nd time. I will replace it. Thanks for the info.
Bexfocus is offline  
    Reply With Quote Quick reply to this message
Old 07-03-2013, 03:31 PM   #5
Focus Enthusiast
 
GBPackFan's Avatar
 
Join Date: Mar 2011
Fan#: 84314
Location: Kalama, WA
What I Drive: 2004 Sonic Blue SVT

Posts: 210
Points 1,858, Level 25
Points: 1,858, Level: 25 Points: 1,858, Level: 25 Points: 1,858, Level: 25
Level Up 58% Completed
Level up: 58% Level up: 58% Level up: 58%
Forum Activity 1%
Activity: 1% Activity: 1% Activity: 1%
FF Reputation: 3 GBPackFan Good Standing Member
Buy-Sell-Trade Rating: (8)
Quote:
Originally Posted by Bexfocus View Post
That is the plug that popped off twice. I must have damaged it the 2nd time. I will replace it. Thanks for the info.
Sent you a PM.
__________________
Current love affair: 2004 SVTF #953 (Josephina - pronounced hoe-se-fin-a)
RIP: 2002 SVTF #2358, Sent to graveyard on June 11, 2013. I will always remember the good times we had!!
This car made my hair go gray, and did not care.
GBPackFan is offline  
    Reply With Quote Quick reply to this message
Old 09-09-2013, 10:42 AM   #6
Focus Rookie
 
Join Date: May 2013
Fan#: 114988
Location: Salt Lake City, United States
What I Drive: WTB 2004 SVT EAP

Posts: 13
FF Reputation: 1 Bexfocus Good Standing Member
Buy-Sell-Trade Rating: (0)
So I finally got around to replacing that plug. It didn't help. I replaced the coil pack, plugs and wires. It revs much smoother now, but it still has no power down low. Do I need to tear that wiring harness apart? I am thinking of replacing the solenoid on the top of the engine head. Anything else I should check?
Bexfocus is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Pitch Black ZX3
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:40 PM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1