gauge cluster - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Reply
 
LinkBack Thread Tools Display Modes
Old 06-01-2013, 10:27 AM   #1
Focus Enthusiast
 
Join Date: Dec 2004
Fan#: 16697
Location: Brandon, Florida
What I Drive: 2004 Blue SVT ZX3

Posts: 503
Points 719, Level 14
Points: 719, Level: 14 Points: 719, Level: 14 Points: 719, Level: 14
Level Up 19% Completed
Level up: 19% Level up: 19% Level up: 19%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 GonePostal Good Standing Member
Buy-Sell-Trade Rating: (1)
gauge cluster

The main light will no longer work but needles do light up as well as radio and air conditioning lighting. The dim light switch does work for the radio and AC so that can't be the issue. Will I need to replace the entire gauge cluster or does this just require a light bulb change?


__________________
VF Rear Mount, Ford Racing STS, FC 65mm TB, RT Hi-Flow Cat, b16sir1991 Air Ram Kit, KW Coilovers, XCal II Tune, Grounding Wire Kit, Taylor Thundervolts w/Motorcraft Coppers, Euro Grille, Borla
GonePostal is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-01-2013, 10:39 AM   #2
Vince your Moderator
 
freemind's Avatar
 
Join Date: Jul 2009
Fan#: 67513
Location: Seattle, WA
What I Drive: 2002 ZX3 and a 2010 Focus SE (Work)

Posts: 5,042
Points 7,219, Level 56
Points: 7,219, Level: 56 Points: 7,219, Level: 56 Points: 7,219, Level: 56
Level Up 35% Completed
Level up: 35% Level up: 35% Level up: 35%
Forum Activity 6%
Activity: 6% Activity: 6% Activity: 6%
FF Reputation: 24 freemind Great Standing Member
Buy-Sell-Trade Rating: (23)
The inverter sounds like it has given up the ghost. You can always make sure that all the connectors are seated correctly first. In the SVT the OEM inverter resides in the small oil pressure cluster.

Do you have a digital multimeter?
__________________
133whp-126ftlbsTQ Eclipse CD8443,Eclipse PA5422, JBL GTO751EZ, PPI 356cs(Rebranded A/D/S 346cs), JBL p1024, SubThump enclosure, RAAmat BXT, Damplifier Pro

Hatch Nation #140
Caeci caecos ducentes
freemind is offline  
    Reply With Quote Quick reply to this message
Old 06-10-2013, 04:59 AM   #3
Focus Enthusiast
 
Join Date: Dec 2004
Fan#: 16697
Location: Brandon, Florida
What I Drive: 2004 Blue SVT ZX3

Posts: 503
Points 719, Level 14
Points: 719, Level: 14 Points: 719, Level: 14 Points: 719, Level: 14
Level Up 19% Completed
Level up: 19% Level up: 19% Level up: 19%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 GonePostal Good Standing Member
Buy-Sell-Trade Rating: (1)
No, I do not have a meter. Initially, when the problem first started happening, just a tap on top of the panel would make the light come back on. This remedy no longer works. Thanks for the input, freemind.
__________________
VF Rear Mount, Ford Racing STS, FC 65mm TB, RT Hi-Flow Cat, b16sir1991 Air Ram Kit, KW Coilovers, XCal II Tune, Grounding Wire Kit, Taylor Thundervolts w/Motorcraft Coppers, Euro Grille, Borla
GonePostal is offline  
    Reply With Quote Quick reply to this message
Old 06-10-2013, 12:48 PM   #4
Vince your Moderator
 
freemind's Avatar
 
Join Date: Jul 2009
Fan#: 67513
Location: Seattle, WA
What I Drive: 2002 ZX3 and a 2010 Focus SE (Work)

Posts: 5,042
Points 7,219, Level 56
Points: 7,219, Level: 56 Points: 7,219, Level: 56 Points: 7,219, Level: 56
Level Up 35% Completed
Level up: 35% Level up: 35% Level up: 35%
Forum Activity 6%
Activity: 6% Activity: 6% Activity: 6%
FF Reputation: 24 freemind Great Standing Member
Buy-Sell-Trade Rating: (23)
^This totally sounds like a bad connection issue. Unplug the gauge cluster connectors(there should be 2 of them, push in on the main plug while moving the lever to the left)on the back of the cluster. Then re-seat them(installation is the same as removal). Check to see if they work. It only takes your time this way.
__________________
133whp-126ftlbsTQ Eclipse CD8443,Eclipse PA5422, JBL GTO751EZ, PPI 356cs(Rebranded A/D/S 346cs), JBL p1024, SubThump enclosure, RAAmat BXT, Damplifier Pro

Hatch Nation #140
Caeci caecos ducentes
freemind is offline  
    Reply With Quote Quick reply to this message
Old 06-12-2013, 04:20 PM   #5
Focus Rookie
 
Join Date: Oct 2012
Fan#: 104734
Location: Ottawa, Canada
What I Drive: 2004 Pitch Black/Red Focus SVT

Posts: 18
FF Reputation: 1 josh6025 Good Standing Member
Buy-Sell-Trade Rating: (0)
I have been having the same issue, I've even gone as far as switching clusters and I was still having the same issue.

How likely is it that the inverter is what needs to be replaced? How much is an inverter and how easy it is to replace?

I have a 2004 SVT (ZX5 body)
josh6025 is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Pitch Black ZX3
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 11:29 PM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1