No brake lights, turn signals, or hazards - Page 2 - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Reply




 
LinkBack Thread Tools Display Modes
Old 01-29-2013, 11:54 PM   #11
Focus Rookie
 
Join Date: Jun 2012
Fan#: 100055
Location: Ft Worth, TX
What I Drive: 2003 black SVT

Posts: 10
FF Reputation: 1 bazelightyear Good Standing Member
Buy-Sell-Trade Rating: (0)
So after pulling and untaping the entire rear harness, I found nothing out of the ordinary. I did however pull the bcm, and what I found was some SERIOUS corrosion on all of the connectors. I would post a picture of just how bad it is, but I'm posting from my phone and can't figure it out... So anyways, I'm about to head to Walmart to pick up some electrical parts cleaner, and I'm reeaally hoping it'll do the trick.
__________________
Proud owner of the slowest SVTF in the world... Seriously.
bazelightyear is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-30-2013, 12:22 AM   #12
FF's Night Security
 
sleepyboy's Avatar
 
Join Date: Nov 2004
Fan#: 15335
Location: SW Houston, TX, United States
What I Drive: 01' Yellow ZX3 euro, 04' ZX5 SVT

Posts: 27,738
Points 148,751, Level 100
Points: 148,751, Level: 100 Points: 148,751, Level: 100 Points: 148,751, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 73%
Activity: 73% Activity: 73% Activity: 73%
FF Reputation: 51 sleepyboy Excellent Standing Member
Buy-Sell-Trade Rating: (11)
Try to post a pic if you can.
__________________
I started out with nothing and I still have most of it left

Hatch Nation #15 (Ole' Yeller') & #150 (The SVT)
Moderator for
Technical Chat
Zetec Performance Chat
Southern Fanatics Chat
sleepyboy is online now  
    Reply With Quote Quick reply to this message
Old 01-30-2013, 04:25 PM   #13
Focus Rookie
 
Join Date: Jun 2012
Fan#: 100055
Location: Ft Worth, TX
What I Drive: 2003 black SVT

Posts: 10
FF Reputation: 1 bazelightyear Good Standing Member
Buy-Sell-Trade Rating: (0)


I tried cleaning the corrosion, and still nothing. I'm beat.
__________________
Proud owner of the slowest SVTF in the world... Seriously.

Last edited by whynotthinkwhynot; 01-31-2013 at 05:42 AM.
bazelightyear is offline  
    Reply With Quote Quick reply to this message
Old 01-31-2013, 01:42 AM   #14
FF's Night Security
 
sleepyboy's Avatar
 
Join Date: Nov 2004
Fan#: 15335
Location: SW Houston, TX, United States
What I Drive: 01' Yellow ZX3 euro, 04' ZX5 SVT

Posts: 27,738
Points 148,751, Level 100
Points: 148,751, Level: 100 Points: 148,751, Level: 100 Points: 148,751, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 73%
Activity: 73% Activity: 73% Activity: 73%
FF Reputation: 51 sleepyboy Excellent Standing Member
Buy-Sell-Trade Rating: (11)
Holy cow that's some corrosion!

At this point I would start checking all the grounds everywhere, especially after seeing the BCM. The car was never in a flood was it? You may also want to try swapping out the headlight switch. I had to do that after having a similar problem like yours. This was after I replaced the Hazard switch a few times through the years. It's been years since I had a problem with the lights now.
__________________
I started out with nothing and I still have most of it left

Hatch Nation #15 (Ole' Yeller') & #150 (The SVT)
Moderator for
Technical Chat
Zetec Performance Chat
Southern Fanatics Chat
sleepyboy is online now  
    Reply With Quote Quick reply to this message
Old 01-31-2013, 05:45 AM   #15
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 Focus Wagon; 13 C-Max SEL

Posts: 20,437
Points 29,433, Level 99
Points: 29,433, Level: 99 Points: 29,433, Level: 99 Points: 29,433, Level: 99
Level Up 66% Completed
Level up: 66% Level up: 66% Level up: 66%
Forum Activity 21%
Activity: 21% Activity: 21% Activity: 21%
FF Reputation: 271 whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
That's not going to clean off with electrical parts cleaner. You need scotchbrite pads or a new module. FYI: grease on the terminals will prevent future corrosion. A large container of dielectric grease is not as expensive as purchasing it in small quantities.
__________________
Be eclectic.
---The Complete How-To Archive--

Moderating everything now, let me know if I can help.

Quote:
Originally Posted by the user formerly known as ZX3_Chick View Post
You're special aren't you.
whynotthinkwhynot is online now  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Pitch Black ZX3
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:22 PM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1