Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum

Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum (
-   General Technical Chat (
-   -   Oxygen Sensors, OL faults, and crazy volts (

SanduskySerpents 01-20-2013 12:48 AM

Oxygen Sensors, OL faults, and crazy volts
My 02 Zetec is stuck in open loop fault. My o2 sensors are also reading some interesting voltages. Sometimes while engine running there is 0v both sensors, when I turn off the car with key in I read .005v both or .065v both. Also with checking connection and wires it has read 0v upstream and 1.250v down, this was key in engine off so I started it to see what happens and upstream hovered below .050 volts And downstream stayed at 1.250v. I have no ideas of what to make of these readings. It runs like crap and is not drivable. I tried to find melted wires and opened some of the loom but came up with nothing. Not sure if relevant but TPS reads at 18%.

jetrinka 01-20-2013 01:11 AM

Any codes?

SanduskySerpents 01-20-2013 01:33 AM

None. Not even pending its weird. I assume because it can't complete a drive cycle it's cant trip them.

jetrinka 01-20-2013 01:43 AM

That shouldn't happen although its strange that it wouldn't recognize these readings from the O2 sensor and set a code.

The upstream sensor should vary between .2 and .8 volts under ideal conditions quite quickly. What are you using to monitor these voltages? I doubt you can get any good/believable readings from them though as they have to be fairly hot before they can begin working reliably.

The car is supposed to run in open loop for a certain amount of time on a cold startup. What is the history on this car? Have you verified that it has a decent RPM signal while cranking and running, and that it has the basics needed for combustion? After those are verified i'd start looking into whether or not the ECU has all the powers and grounds needed to operate. Its strange that it runs so poorly and doesn't set a code and that is why I say that.

1turbofocus 01-20-2013 09:26 AM

Many things could cause this , bad o2 , blown fuse to the o2 , fuel issues etc

How old is the front o2 , have you checked the voltage to the o2 ie fuse


whynotthinkwhynot 01-20-2013 09:34 AM

From those voltages, it seems to me that the downstream O2 is the problem. Have you tried running with it disconnected? There should be a connector somewhere up there so you can just unplug it.

If you can get it running evenly, I'd like to know what the voltage is across the battery with the engine idling. Anything more than 14.9v is bad, and you will need a new alternator.

Also, you say that the TPS is at 18%, do you mean that it is reading 18% at idle/rest?

SanduskySerpents 01-20-2013 10:49 AM

Snap On ethos is how I am monitoring these voltages. The scanner says its in open loop fault, not open loop waiting for conditions for closed.
I will check the o2 fuse voltage with my Dvom and report back. I really have no idea about how old these sensors are but I doubt they are original stock.
The car cranks fine and first idles smooth for about a 3 seconds then goes to shit.
In order for a MIL to be illuminated it needs to trip the DTC twice for a type B code or once for a type A. Most codes are type B. your type a flashes the engine light.
In order for it to trip at least once it needs to complete its drive cycle test. Certain conditions are met during a test for Sensor and tested. I'm not certain if O2 sensors are a continuous monitor system or a non continuous. Either way its never lighting because its not meeting its conditions.
Also my tps reading is 18% at idle. I think I have a wiring issue.

whynotthinkwhynot 01-20-2013 10:57 AM

Yeah, if it was running ok before and then suddenly it starts reading 18%, that's a problem. It could be that the TPS itself is bad though typically those go bad by putting out low voltage not high= run lean.

Did you try disconnecting that downstream sensor? That will throw a code, but if it is the only thing that is the problem, then everything else should clear up. I'd also remove the O2 heater fuse for that circuit. This will also throw a code, but that's ok if it runs like that. At least you'll know where to start looking. Anything more than 1v is not right for an O2 sensor.

SanduskySerpents 01-20-2013 01:09 PM

So I took out the harness looks like a part # 1m5t-12a690 not all the tag was there but when I disconnected the gray connecter my volts obviously dropped to 0v with koeo , and my tps went to 17% . I did find someone replaced the upstream o2 connector because the wires where just twisted together. I fixed that but I don't think this is where my short is. I don't want it to be the harness to the PCM. I didn't find anything else in the harness I pulled except it smelled of antifreeze.

mikebontoft 01-20-2013 02:26 PM

TPS idle values will not read 0% on all vehicles. I've seen up to 20% on a normal running vehicle. That's also where my focus was at idle.

All times are GMT -5. The time now is 03:47 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.