bad cruise control - need parts name for replacement - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Reply




 
LinkBack Thread Tools Display Modes
Old 12-23-2012, 09:34 PM   #1
Focus Enthusiast
 
Join Date: Sep 2007
Fan#: 49997
Location: Pflugerville, TX
What I Drive: 2006 Liquid Grey ZX4 SES

Posts: 436
Points 3,953, Level 40
Points: 3,953, Level: 40 Points: 3,953, Level: 40 Points: 3,953, Level: 40
Level Up 2% Completed
Level up: 2% Level up: 2% Level up: 2%
Forum Activity 7%
Activity: 7% Activity: 7% Activity: 7%
FF Reputation: 1 Technoholic Good Standing Member
Buy-Sell-Trade Rating: (1)
bad cruise control - need parts name for replacement

Hi,
One weekend last summer, I found my car's cruise control wasn't working at all when I was driving home from DC.

Ford replaced my cruise control module that is behind the steering wheel I was told. Cheaper this one. And it turns out my cruise control was not fully restored and it cost a couple hundred bucks to replace the one under the hood.

The part that I want to replace under the hood, what is the name of this? Or if anyone have had the same experience, what was the solution?

From time to time while on the road, sometimes my cruise control stays on for long. Or at one point, it keeps shutting off. Sometimes cruise control won't come on at all.

The car is '06 Focus SES sedan.

Thanks in advance!


__________________
2006 Ford Focus SES ZX4 Liquid Grey
Technoholic is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-24-2012, 08:43 AM   #2
Focus Addict
 
Join Date: Jan 2010
Fan#: 72526
Location: Sugar Land,TX ex MN, TX
What I Drive: 2010 Transit Connect

Posts: 1,046
Points 626, Level 12
Points: 626, Level: 12 Points: 626, Level: 12 Points: 626, Level: 12
Level Up 52% Completed
Level up: 52% Level up: 52% Level up: 52%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 15 mikeeshaq Great Standing Member
Buy-Sell-Trade Rating: (0)
I do not have a 2006 Ford wiring manual

Taken from a 2010 Ford transit Connect Wiring manaul

Two main modules:
1. Electronic throttle control [ETC] module
2. Powertrain Control module (PCM)

Bring it back to Ford
mikeeshaq is offline  
    Reply With Quote Quick reply to this message
Old 12-24-2012, 01:47 PM   #3
Focus Enthusiast
 
Join Date: Sep 2007
Fan#: 49997
Location: Pflugerville, TX
What I Drive: 2006 Liquid Grey ZX4 SES

Posts: 436
Points 3,953, Level 40
Points: 3,953, Level: 40 Points: 3,953, Level: 40 Points: 3,953, Level: 40
Level Up 2% Completed
Level up: 2% Level up: 2% Level up: 2%
Forum Activity 7%
Activity: 7% Activity: 7% Activity: 7%
FF Reputation: 1 Technoholic Good Standing Member
Buy-Sell-Trade Rating: (1)
Due to lack of response, I took a closer look to the cruise control module. Found the part number.

The mechanic pointed this part out to me, the part number is 6S43-9C735-AA, it is on eBay currently for $70 + shipping. I don't know if this is a good price, but it sure beats the hell out of getting through Ford.

[Edit] $180 + labor if through Ford. I just ordered the one on eBay.
__________________
2006 Ford Focus SES ZX4 Liquid Grey
Technoholic is offline  
    Reply With Quote Quick reply to this message
Old 12-26-2012, 11:38 PM   #4
Focus Enthusiast
 
Join Date: Feb 2012
Fan#: 95211
Location: northeast, PA
What I Drive: 2007 ZX3

Posts: 316
Points 1,224, Level 19
Points: 1,224, Level: 19 Points: 1,224, Level: 19 Points: 1,224, Level: 19
Level Up 24% Completed
Level up: 24% Level up: 24% Level up: 24%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 9 Lscman Good Standing Member
Buy-Sell-Trade Rating: (1)
Are you planning to replace perfectly good cruise control parts one at a time until you find the one part that's bad? Good luck but that approach may be incredibly costly and time consuming. I would suggest referring to the factory manual to troubleshoot the system so the defective component can be identified and replaced. The part you bought is the servo module assembly. The trouble could be interconnect wiring, pedal interlock switches, steering clock spring, steering wheel switches or throttle actuator cable. Intermittent trouble can be the servo module assembly, but I'd rule other parts out first.
Lscman is offline  
    Reply With Quote Quick reply to this message
Old 12-28-2012, 05:16 AM   #5
Focus Jr. Enthusiast
 
Join Date: Oct 2012
Fan#: 105358
Location: virginia beach, VA
What I Drive: 2002 pitch black svt

Posts: 45
FF Reputation: 1 rsnow Good Standing Member
Buy-Sell-Trade Rating: (0)
im with the above post.... i work at a dealer and dont see may servo problems anymore. It may be as simple as a deactivation switch messing up.
rsnow is offline  
    Reply With Quote Quick reply to this message
Old 12-29-2012, 07:13 AM   #6
Focus Enthusiast
 
Join Date: Jul 2009
Fan#: 67546
Location: South Lyon, MI
What I Drive: 2002 Blue SE

Posts: 437
Points 1,013, Level 17
Points: 1,013, Level: 17 Points: 1,013, Level: 17 Points: 1,013, Level: 17
Level Up 13% Completed
Level up: 13% Level up: 13% Level up: 13%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 5 alz focus Good Standing Member
Buy-Sell-Trade Rating: (0)
Having any problems with your brake lights lately?
That circuit is connected to the cc system.
__________________
Al
2002 Focus SE Zetec ATX
2000 Focus SE SPI ATX
2006 Freestyle SEL AWD
alz focus is offline  
    Reply With Quote Quick reply to this message
Old 12-29-2012, 10:56 AM   #7
Focus Enthusiast
 
Join Date: Jul 2009
Fan#: 67546
Location: South Lyon, MI
What I Drive: 2002 Blue SE

Posts: 437
Points 1,013, Level 17
Points: 1,013, Level: 17 Points: 1,013, Level: 17 Points: 1,013, Level: 17
Level Up 13% Completed
Level up: 13% Level up: 13% Level up: 13%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 5 alz focus Good Standing Member
Buy-Sell-Trade Rating: (0)
Give this a shot. I copied it from another post. It was how I figured out my cc problems.

The test is basically this: you're going to be turning the ignition key on and off repeatedly and then hitting the cruise control buttons quickly in a specific sequence, and then the cruise control light will blink repeatedly, and the number of blinks tells you where the fault is. It's easy to do once you get it sorted in your head and you won't mess anything up if you don't get it right the first time.

If it's a manual, don't depress the clutch. If it's an automatic leave it in park. First, turn the ignition to the accessory/run position but don't start it. Press and hold the CC off switch and then repeatedly turn the ignition from run to off and back to run again, you should do this 3 or 4 times. End this sequence with the ignition in the run position and then let go of the off switch, and you should see your CC light blink once, which means it's ready to run the self diagnostic. If it flashes 5 times at this point then it's a faulty speed control module, which is that servo I mentioned above. Quickly after the light blinks (like a second after), you then need to hit the other cruise control buttons in this order, and you will need to hit them fairly quickly for the test to proceed:

1. On
2. Resume
3. Coast
4. Set/accel

The CC light should blink once after each button you hit. Kind of take your time hitting the buttons and it's easier to keep track of the flashes, which is important at the end because you need to count the number of flashes that come after you hit "set". There won't be an immediate flash after you hit "set", there will be a slight delay, and then will come another short series of flashes. This next part is all verbatim (except for the parenthesis) from the Ford guide I'm translating here.

0 Flashes (no flash after last button is pushed): suspect circuitry or speed control steering wheel switches.
1 Flash: Static test passed (cruise control should work)
2 Flashes: BPP (brake pedal position) switch is damaged, circuit is damaged, or the brake or clutch pedal was applied during test.
3 Flashes: Brake deactivation switch is open or circuit is damaged.
4 Flashes: Indicates the speed signal circuit is open or damaged (wheel speed sensors, ETC)
5 Flashes: Suspect circuitry or module.
__________________
Al
2002 Focus SE Zetec ATX
2000 Focus SE SPI ATX
2006 Freestyle SEL AWD
alz focus is offline  
    Reply With Quote Quick reply to this message
Old 12-29-2012, 11:08 AM   #8
Focus Enthusiast
 
Join Date: Feb 2012
Fan#: 95211
Location: northeast, PA
What I Drive: 2007 ZX3

Posts: 316
Points 1,224, Level 19
Points: 1,224, Level: 19 Points: 1,224, Level: 19 Points: 1,224, Level: 19
Level Up 24% Completed
Level up: 24% Level up: 24% Level up: 24%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 9 Lscman Good Standing Member
Buy-Sell-Trade Rating: (1)
That's a really neat procedure. It could come in handy to try, especially when the system fails intermittently. It's hard to troubleshoot & repair stuff when it's working most of the time. This test procedure could be tried in a couple minutes when it shuts down on the road. Maybe print it out and keep it in your glovebox.
Lscman is offline  
    Reply With Quote Quick reply to this message
Old 01-15-2013, 05:02 PM   #9
Focus Rookie
 
Join Date: Aug 2009
Fan#: 68286
Location: Adrian, MI
What I Drive: 2003 Black ZX5

Posts: 5
FF Reputation: 1 nevercell Good Standing Member
Buy-Sell-Trade Rating: (0)
I'm having the same problem for the most part.

Mine stopped working the other day. When I try to activate it, the light comes on but doesn't engage. The speed falls down and the cruise control kicks off, making a bad grinding noise.

I used this test and didn't get the same results. When I press "set" it instantly blinked like the rest of the buttons and then the cruise control module made a horrible noise at the same time. So the light was instant, no delay, and no blinks afterwards. I'd like to assume it's the module but other people have mentioned the computer or buttons. With such a horrible noise, I don't see how it could be anything but the module. Any suggestions? Thank you.


Quote:
Originally Posted by alz focus View Post
Give this a shot. I copied it from another post. It was how I figured out my cc problems.

The test is basically this: you're going to be turning the ignition key on and off repeatedly and then hitting the cruise control buttons quickly in a specific sequence, and then the cruise control light will blink repeatedly, and the number of blinks tells you where the fault is. It's easy to do once you get it sorted in your head and you won't mess anything up if you don't get it right the first time.

If it's a manual, don't depress the clutch. If it's an automatic leave it in park. First, turn the ignition to the accessory/run position but don't start it. Press and hold the CC off switch and then repeatedly turn the ignition from run to off and back to run again, you should do this 3 or 4 times. End this sequence with the ignition in the run position and then let go of the off switch, and you should see your CC light blink once, which means it's ready to run the self diagnostic. If it flashes 5 times at this point then it's a faulty speed control module, which is that servo I mentioned above. Quickly after the light blinks (like a second after), you then need to hit the other cruise control buttons in this order, and you will need to hit them fairly quickly for the test to proceed:

1. On
2. Resume
3. Coast
4. Set/accel

The CC light should blink once after each button you hit. Kind of take your time hitting the buttons and it's easier to keep track of the flashes, which is important at the end because you need to count the number of flashes that come after you hit "set". There won't be an immediate flash after you hit "set", there will be a slight delay, and then will come another short series of flashes. This next part is all verbatim (except for the parenthesis) from the Ford guide I'm translating here.

0 Flashes (no flash after last button is pushed): suspect circuitry or speed control steering wheel switches.
1 Flash: Static test passed (cruise control should work)
2 Flashes: BPP (brake pedal position) switch is damaged, circuit is damaged, or the brake or clutch pedal was applied during test.
3 Flashes: Brake deactivation switch is open or circuit is damaged.
4 Flashes: Indicates the speed signal circuit is open or damaged (wheel speed sensors, ETC)
5 Flashes: Suspect circuitry or module.
nevercell is offline  
    Reply With Quote Quick reply to this message
Old 01-15-2013, 06:05 PM   #10
Focus Addict
 
6SPD_soul's Avatar
 
Join Date: Feb 2008
Fan#: 53637
Location: Gainesville, FL
What I Drive: 2003 Comp Orange EAP SVT

Posts: 1,488
Points 2,670, Level 31
Points: 2,670, Level: 31 Points: 2,670, Level: 31 Points: 2,670, Level: 31
Level Up 47% Completed
Level up: 47% Level up: 47% Level up: 47%
Forum Activity 6%
Activity: 6% Activity: 6% Activity: 6%
FF Reputation: 24 6SPD_soul Great Standing Member
Buy-Sell-Trade Rating: (1)
Maybe try to get someone else to run the diagnostic while you listen more closely to the servo box, if the noise is definitely coming from there then you've found your problem. In fact I think you've found your problem anyway, the last part of the self diagnostic activates the mechanics in the cruise servo, and even a properly functioning servo will make an audible noise (at least in the focus).

The servo box can be dissasembled and inspected, I actually fixed one on someone elses ZX3. I was mostly curious about how it works (it's kind of cool, it's actually an electromagnet that couples with the cruise throttle cable, and the electromagnet moves back and forth from a stepper motor to change throttle opening. It's mechanically failsafe since the electromagnet is the part that couples with the cruise throttle cable) and it turned out to be repairable.

I don't know about why you got an immediate single flash after hitting set. The car I described above had dealer installed cruise control and I had no way to run the self diagnostic, so I can't compare it to your self diagnostic results.
6SPD_soul is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:45 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1