ZETEC Engine stumble - SOLVED - Page 10 - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Reply




 
LinkBack Thread Tools Display Modes
Old 03-14-2008, 11:28 PM   #91
Sooo Fresh
 
dougy fresh's Avatar
 
Join Date: Sep 2004
Fan#: 12780
Location: Plymouth, MI
What I Drive: 2000 zx3, 1978 mustang II 302

Posts: 2,114
Points 2,896, Level 32
Points: 2,896, Level: 32 Points: 2,896, Level: 32 Points: 2,896, Level: 32
Level Up 98% Completed
Level up: 98% Level up: 98% Level up: 98%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 4 dougy fresh Good Standing Member
Buy-Sell-Trade Rating: (2)
wow awsome i really need help with this problem and thank god its solved
__________________
ZETECCREW#208
Hatch Nation # 74
dougy fresh is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-16-2008, 08:29 PM   #92
Focus Jr. Enthusiast
 
Join Date: Mar 2008
Fan#: 54016
Location: mi.
What I Drive: 2001 silver SE

Posts: 27
FF Reputation: 1 silverspeck Good Standing Member
Buy-Sell-Trade Rating: (0)
oops
silverspeck is offline  
    Reply With Quote Quick reply to this message
Old 03-16-2008, 09:18 PM   #93
Focus Enthusiast
 
Join Date: Aug 2007
Fan#: 49714
Location: New York, United States
What I Drive: 00 zx3 01 zx3

Posts: 289
FF Reputation: 23 slo1 Great Standing Member
Buy-Sell-Trade Rating: (9)
Quote:
Originally Posted by sqrly View Post
sounds like a cluster problem
Or you need a new battery/ have a poor ground.
slo1 is offline  
    Reply With Quote Quick reply to this message
Old 04-25-2008, 08:26 PM   #94
Focus Rookie
 
Maniaco760's Avatar
 
Join Date: Nov 2005
Fan#: 29754
Location: San Diego, California
What I Drive: 2003 White ZX3

Posts: 9
FF Reputation: 1 Maniaco760 Good Standing Member
Buy-Sell-Trade Rating: (0)
anybody got any more pics or at least larger pics to get a sense of where that pvc pipe is located?? Thanks!
Maniaco760 is offline  
    Reply With Quote Quick reply to this message
Old 04-29-2008, 05:45 PM   #95
Focus Jr. Enthusiast
 
Join Date: Aug 2004
Fan#: 11667
Location: Monterey, CA
What I Drive: 2001 White ZX3

Posts: 27
FF Reputation: 1 JFridey Good Standing Member
Buy-Sell-Trade Rating: (0)
bwojdyla
Lol you are the man, I've been pounding my head just knowing I had a vacume leak, practicly spraying every hose I could find with WD40.
Reading your post I knew exactly where to look, and what do you know, right where the bend is it was just totaly clapsed. I'll be ordering a new hose asap.

Could this hose colapse be messing up my MPG a little?
JFridey is offline  
    Reply With Quote Quick reply to this message
Old 04-29-2008, 05:50 PM   #96
Focus Jr. Enthusiast
 
Join Date: Aug 2004
Fan#: 11667
Location: Monterey, CA
What I Drive: 2001 White ZX3

Posts: 27
FF Reputation: 1 JFridey Good Standing Member
Buy-Sell-Trade Rating: (0)
I really think this post needs to be a sticky btw.. Maybe start a fresh thread starting with your explination and your pictures. It's got my vote.
JFridey is offline  
    Reply With Quote Quick reply to this message
Old 05-23-2008, 11:40 PM   #97
Focus Rookie
 
Join Date: Dec 2005
Fan#: 30544
Location: chicago
Posts: 21
FF Reputation: 1 grimple1 Good Standing Member
Buy-Sell-Trade Rating: (0)
stupid vibration/rough idle problems are back.... yeah ford!
grimple1 is offline  
    Reply With Quote Quick reply to this message
Old 08-25-2008, 04:34 AM   #98
Focus Rookie
 
Join Date: Aug 2008
Fan#: 58723
Location: Newport
What I Drive: 2000 Silver 1.8 Zetec

Posts: 2
FF Reputation: 1 Steeeev Good Standing Member
Buy-Sell-Trade Rating: (0)
great site guys - even old threads are still useful !

checked the pipe today in the rain (UK weather!!) and guess what - a hole. Thanks for your help
Steeeev is offline  
    Reply With Quote Quick reply to this message
Old 08-25-2008, 07:44 AM   #99
Focus Rookie
 
Join Date: Apr 2006
Fan#: 34207
Location: dayton, ohio
What I Drive: 02 ZX5

Posts: 7
FF Reputation: 1 satoripooh Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by grimple1 View Post
stupid vibration/rough idle problems are back.... yeah ford!
me too. i've changed the hose, replaced the DPFE sensor, full tune up (plugs, wires & air filter)...and STILL the stumble is back. got plenty of power, just a stupid stumble.

i'm gonna assume it's a stray vacc leak until i prove that wrong, then i'm gonna be in the O2 sensor camp. i wondered if maybe having the exhaust/gas regulation jacked up for a while didn't torch the O2 sensor.

we'll see! till then to ford and the wonderful zetec stumble!
satoripooh is offline  
    Reply With Quote Quick reply to this message
Old 09-03-2008, 03:27 PM   #100
Focus Rookie
 
Join Date: Sep 2008
Fan#: 58963
Location: Loganville GA
What I Drive: 2000 Blue ZX3

Posts: 1
FF Reputation: 1 bigman2416 Good Standing Member
Buy-Sell-Trade Rating: (0)
Had the same problem a few months ago. Took it to the shop and they claimed the timing belt had slipped. After they fixed that it ran ok for awhile but I just noticed the stumbling again. Checked the hose and sure enough its collapsed. Gonna get a new hose and hopefully this will solve the problem!
bigman2416 is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Zetec engine identification mr_force ZETEC Performance (2000-2004) 15 09-05-2007 04:00 PM
Vehicle Maintenence Schedule S2 General Technical Chat 0 05-08-2006 10:57 AM
New Engine Technology 2004SVTAutoXer General Car Chat Lounge 8 04-26-2006 06:06 PM
Zetec Stumble Fix...Help? jcarian General Technical Chat 1 03-11-2005 11:00 PM


All times are GMT -5. The time now is 04:43 PM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1