No Boost!! PLEASE HELP!!! - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Forced Induction

General Forced Induction The place to chat about turbochargers, superchargers nitrous systems and custom engine fabrications.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Reply
 
LinkBack Thread Tools Display Modes
Old 06-18-2006, 08:29 PM   #1
Banned
 
Join Date: May 2006
Fan#: 35692
Location: Bel Air, MD 21014
What I Drive: Black 2002 Turbo SVT Focus

Posts: 33
FF Reputation: 1 TurboSVTF Good Standing Member
Buy-Sell-Trade Rating: (0)
No Boost!! PLEASE HELP!!!

Today I installed the Stg1 turbo kit (removed from Mike's 2004 SVTF) to my 2002 SVTF. Idle is fine, everything *seemed* fine. When I went for a drive, under load and when boost should be coming on it sounds like a rev limiter and it makes no boost. It literrally feels like I have a parachute tied to my car and I just cant go. Its as if the computer senses the boost and freaks out.

Just so you know, mods are: Stg1 with T3 upgrade, MAFia (set at 4), 55lb injectors, Greddy BOV, MSD Coil and Wires and OEM Plugs, Ex.Cam Gear (set at 0*-1* Advance - as close to zero as I could get), UDP, No Cat, 3" Exhaust.

I didnt unplug my battery (its in the rear of the car and didnt think of it) til I was already gone. But, I flashed the custom tune and it went just fine.

Also, if its relevant, as soon as I start to drive away, the air fuel (aem wideband) pegs rich (goes below 11:1) and it sort of sputters. It only does that on vey light acceleration. The car also stalled out several times but I figure with all those symptoms that its just learning.

The making no boost is the biggest issue. Do you think its a tune issue or something mechanical. I will tell you, the turbo kit was FINE as it was removed from the car. The BOV is hooked up right, wastegate is hooked up right, etc. Also, I have an RLA6 car, and Mike has a ZED0 car...could that be an issue?

p.s. I ruled out traction control (light doesnt blink, and I also pulled the fuse so it was gone...)

Any ideas??? Im at a loss...

Thanks


TurboSVTF is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-19-2006, 10:35 AM   #2
Focus Fanatic
 
Join Date: Sep 2004
Fan#: 12900
Location: Rockville, MD
What I Drive: 2003 SVT Focus

Posts: 1,643
FF Reputation: 1 crazymechanic Good Standing Member
Buy-Sell-Trade Rating: (1)
the RLS6 vs ZED0 is probably the problem I think. you have to get a tune with the right pcm code
crazymechanic is offline  
    Reply With Quote Quick reply to this message
Old 06-19-2006, 01:29 PM   #3
Focus Addict
 
Join Date: Aug 2005
Fan#: 27198
Location: New Jersey
What I Drive: 2004 SVT Focus

Posts: 560
FF Reputation: 1 TwighlightBlueZx5 Good Standing Member
Buy-Sell-Trade Rating: (1)
yea if u just used the tune mike gave you...thats a problem , you need to have tom send u a new tune....
__________________
2004 Silver SVT Focus
#529 of 1978
TwighlightBlueZx5 is offline  
    Reply With Quote Quick reply to this message
Old 06-19-2006, 01:37 PM   #4
/fail
 
rfinger's Avatar
 
Join Date: Jan 2004
Fan#: 2799
Location: Brighton, TN
What I Drive: F150 FX4

Posts: 3,192
Points 9,957, Level 66
Points: 9,957, Level: 66 Points: 9,957, Level: 66 Points: 9,957, Level: 66
Level Up 77% Completed
Level up: 77% Level up: 77% Level up: 77%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 rfinger Good Standing Member
Buy-Sell-Trade Rating: (6)
well i have used different pcm coded tunes before and it worked just fine for me..............hey russ get that exhaust sent out?
__________________
F150 FX4

"When everything works, it's a sheer joy to drive." - Jeremy Clarkson
rfinger is offline  
    Reply With Quote Quick reply to this message
Old 06-19-2006, 04:51 PM   #5
Banned
 
Join Date: May 2006
Fan#: 35692
Location: Bel Air, MD 21014
What I Drive: Black 2002 Turbo SVT Focus

Posts: 33
FF Reputation: 1 TurboSVTF Good Standing Member
Buy-Sell-Trade Rating: (0)
Actually, it was the airflow meter...well, partly. Now its breaking up once I get into boost around 4k. Its mostly a calibration issue now, so I have a dyno appt. at McNews tommorow to get er fixed up!

I just want to shout out how great Tom is. First, his "performance tune" (pre turbo) was AWESOME. Leaps and bounds over the "H Tune". Second, I called his phone at 10pm last night to leave a message for him to call me in the morning and he answered. He spent time with me, diagnosing as best as possible over the phone, and pointed me right to the problem which I fixed this morning (MAF). I got his kit 2nd hand and he had no issue helping me. Today he called me to tell me the tune/ calibration issue was causing it to break up. He is an awesome guy and I just want to put that out there for everyone. A lot of people like to talk crap about Tom; but when you need him he's there with out hesitation. Tom, you are an absolute asset to the Focus community and Im glad you're here!

Ricky, yes, exhaust went out this AM...DHL picked it up. Im trying to find the slip I got with the waybill but I might have left it in my mailbox at work. Im going up there to get my wifes car so I'll look tonight.
TurboSVTF is offline  
    Reply With Quote Quick reply to this message
Old 06-19-2006, 11:26 PM   #6
/fail
 
rfinger's Avatar
 
Join Date: Jan 2004
Fan#: 2799
Location: Brighton, TN
What I Drive: F150 FX4

Posts: 3,192
Points 9,957, Level 66
Points: 9,957, Level: 66 Points: 9,957, Level: 66 Points: 9,957, Level: 66
Level Up 77% Completed
Level up: 77% Level up: 77% Level up: 77%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 rfinger Good Standing Member
Buy-Sell-Trade Rating: (6)
kewl man when you get some kind of tracking number lemme know
__________________
F150 FX4

"When everything works, it's a sheer joy to drive." - Jeremy Clarkson
rfinger is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Pitch Black ZX3
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:06 PM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1