Big problem...please help - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Forced Induction

General Forced Induction The place to chat about turbochargers, superchargers nitrous systems and custom engine fabrications.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Reply




 
LinkBack Thread Tools Display Modes
Old 06-05-2007, 12:36 PM   #1
Focus Enthusiast
 
Join Date: May 2005
Fan#: 23268
Location: Wisconsin
What I Drive: 1999 Blue ZX2

Posts: 57
FF Reputation: 1 ZX2boosted Good Standing Member
Buy-Sell-Trade Rating: (0)
Exclamation Big problem...please help

Well to let you know i have a ZX2. I just got finished putting in a new turbo (bigger one) and i started my car a while back. Well the idle was shitty...just horrible, It would idle high then go low then back up...like 1200rpms to 500rpms then eventually die. Eventually I took it to the dyno guy today and called him. He said there is something horribly wrong. He's thinking something with the wiring, Well i've never touched the wiring stuff. He said maybe PCM or ground. He says it will probably be like 2000$ for him to fix and find the problem. I've been to him before so i know he's good for his word. But that's a lot. What does anybody think could be wrong. Just help I'm stuck!

http://www.youtube.com/watch?v=-ufHyM79PXs

http://www.youtube.com/watch?v=6wCQnRIUl6A

Any suggestions? He says it's not a tuning issue


__________________
New turbo setup: Garrett T3/TO4E 57 Trim .48 A/R, #'s will follow.
ZX2boosted is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-05-2007, 01:08 PM   #2
Fins Up!
 
Turbo Turtle's Avatar
 
Join Date: Mar 2006
Fan#: 32772
Location: Calera, AL
What I Drive: STi & Miata

Posts: 4,806
Points 21,259, Level 91
Points: 21,259, Level: 91 Points: 21,259, Level: 91 Points: 21,259, Level: 91
Level Up 82% Completed
Level up: 82% Level up: 82% Level up: 82%
Forum Activity 3%
Activity: 3% Activity: 3% Activity: 3%
FF Reputation: 54 Turbo Turtle Excellent Standing Member
Buy-Sell-Trade Rating: (25)
looks like it is starving for fuel to me. it is way lean when it is stubling. check it for vacuum leaks. we need to combine our idles and we would have a good one. mine stumble because of to much fuel.
__________________
Turbo Turtle Garage
Zetec and Duratec Turbo kits, engine building

turboturtlegarage.com
facebook.com/TurboTurtleGarage
TurboTurtleFab@gmail.com
Turbo Turtle is offline  
    Reply With Quote Quick reply to this message
Old 06-05-2007, 01:19 PM   #3
Focus Enthusiast
 
ch435's Avatar
 
Join Date: Feb 2007
Fan#: 43770
Location: Minneapolis, United States
What I Drive: 2005 sonic blue Saleen N2O

Posts: 276
FF Reputation: 2 ch435 Good Standing Member
Buy-Sell-Trade Rating: (0)
Where did you get the turbo? What kind is it?
__________________
Boosted Crew Member #3
Saleen Crew Member #2
ch435 is offline  
    Reply With Quote Quick reply to this message
Old 06-05-2007, 01:58 PM   #4
Focus Enthusiast
 
Join Date: May 2005
Fan#: 23268
Location: Wisconsin
What I Drive: 1999 Blue ZX2

Posts: 57
FF Reputation: 1 ZX2boosted Good Standing Member
Buy-Sell-Trade Rating: (0)
he says that it's not the tune but there is deff things wrong with the tune. He says that the A/F ratio is way to rich at idle. LIke 12:1 then at part throttle it even gets worse. But he says there is something wrong with my voltage in places. Also my battery isn't holding a charge. I just replaced the alternator too not to long ago.
__________________
New turbo setup: Garrett T3/TO4E 57 Trim .48 A/R, #'s will follow.
ZX2boosted is offline  
    Reply With Quote Quick reply to this message
Old 06-05-2007, 03:56 PM   #5
Focus Enthusiast
 
ch435's Avatar
 
Join Date: Feb 2007
Fan#: 43770
Location: Minneapolis, United States
What I Drive: 2005 sonic blue Saleen N2O

Posts: 276
FF Reputation: 2 ch435 Good Standing Member
Buy-Sell-Trade Rating: (0)
do these cars have voltage regulators? My Ford truck does. That could cause voltage irregularities.

I sure think you have a tuning problem. Especially if the idle prob occured after installing the new turbo.

The reason I asked where you got it is places like Focus Sport are very good with support after the sale. (I speak from experience, as I have one)
__________________
Boosted Crew Member #3
Saleen Crew Member #2
ch435 is offline  
    Reply With Quote Quick reply to this message
Old 06-05-2007, 04:34 PM   #6
Focus Enthusiast
 
Join Date: May 2005
Fan#: 23268
Location: Wisconsin
What I Drive: 1999 Blue ZX2

Posts: 57
FF Reputation: 1 ZX2boosted Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by tls_bmx View Post
looks like it is starving for fuel to me. it is way lean when it is stubling. check it for vacuum leaks. we need to combine our idles and we would have a good one. mine stumble because of to much fuel.


what did you find out to be the problem or still don't know, that sounds like the same thing we have. My guy said it's not tuning something else. Obviously the tune is off but there is something more. I dunno seems like it is since i haven't touched anything other then the turbo, manifold, exhaust, piping. nothing. Yea i guess i could have fried my PCM but I always unplugged my battery while doing anything electircal.
__________________
New turbo setup: Garrett T3/TO4E 57 Trim .48 A/R, #'s will follow.
ZX2boosted is offline  
    Reply With Quote Quick reply to this message
Old 06-05-2007, 04:44 PM   #7
FF Affiliate
 
1turbofocus's Avatar
 
Join Date: Oct 2003
Fan#: 1123
Location: Belmont, NC
What I Drive: 2000 ZX3 / 2002 SVT Turbocharged

Posts: 22,806
Points 53,000, Level 100
Points: 53,000, Level: 100 Points: 53,000, Level: 100 Points: 53,000, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 42%
Activity: 42% Activity: 42% Activity: 42%
FF Reputation: 154 1turbofocus Excellent Standing Member 1turbofocus Excellent Standing Member
Buy-Sell-Trade Rating: (28)
What is he saying the issues are and what is not geting the correct voltage

Tom
__________________
Focus-Power: Your #1 Source for Ford Focus Speed, Tuning & Performance!

Customer Support
AIM: hpdyno
Email: hpdyno@aol.com
Phone: 704-249-3745
Site: focus-power.com

Elder 1turbofocus
1turbofocus is offline  
    Reply With Quote Quick reply to this message
Old 06-05-2007, 06:56 PM   #8
LETS TURN DIRT!!!!
 
03OrangeSVT's Avatar
 
Join Date: Feb 2005
Fan#: 19169
Location: Piketon, OH
What I Drive: MINI Cooper S TURBO

Posts: 11,906
FF Reputation: 152 03OrangeSVT Excellent Standing Member 03OrangeSVT Excellent Standing Member
Buy-Sell-Trade Rating: (5)
Sorta sounds like a bad Throttle Position sensor
__________________
[B]1951 McCormick FARMALL M
2007 MINI Cooper S Turbo... new project car
1998 Chevy 3500 Ext cab, long bed, 4x4, duelly, turbo diesel
2004 Harley V-Rod.... sex on wheels
2011 Harley Electra Glide Ultra Limited
[/b]
03OrangeSVT is offline  
    Reply With Quote Quick reply to this message
Old 06-05-2007, 08:57 PM   #9
Focus Enthusiast
 
Join Date: May 2005
Fan#: 23268
Location: Wisconsin
What I Drive: 1999 Blue ZX2

Posts: 57
FF Reputation: 1 ZX2boosted Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by 1turbofocus View Post
What is he saying the issues are and what is not geting the correct voltage

Tom

I wish he could type my up because I even have a hard time translating the problem. He said everything is spiking constantly and that the battery didn't hold a charge, yea that's not very good to explain. I can put some datalogs up here if it helps.
__________________
New turbo setup: Garrett T3/TO4E 57 Trim .48 A/R, #'s will follow.
ZX2boosted is offline  
    Reply With Quote Quick reply to this message
Old 06-06-2007, 07:22 AM   #10
FF Affiliate
 
1turbofocus's Avatar
 
Join Date: Oct 2003
Fan#: 1123
Location: Belmont, NC
What I Drive: 2000 ZX3 / 2002 SVT Turbocharged

Posts: 22,806
Points 53,000, Level 100
Points: 53,000, Level: 100 Points: 53,000, Level: 100 Points: 53,000, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 42%
Activity: 42% Activity: 42% Activity: 42%
FF Reputation: 154 1turbofocus Excellent Standing Member 1turbofocus Excellent Standing Member
Buy-Sell-Trade Rating: (28)
Need something to help you , Need more info

Tom
__________________
Focus-Power: Your #1 Source for Ford Focus Speed, Tuning & Performance!

Customer Support
AIM: hpdyno
Email: hpdyno@aol.com
Phone: 704-249-3745
Site: focus-power.com

Elder 1turbofocus
1turbofocus is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Big Suspension Problem You Should All Be Aware Of!!! cbrenn71 Brakes, Suspension & Body Chassis 57 08-30-2007 12:56 AM
HELP!!! Big Problems: TWO 2001 Ford Focuses stainless_delorean General Technical Chat 18 01-12-2007 04:35 PM
MAF Problem or PCM problem? JonsLilBlueRocket General Technical Chat 0 01-21-2006 12:27 PM
Auto Door lock problem DjShaggy General Technical Chat 4 12-17-2005 07:14 PM
Is this a fuel pump problem? Help! Rockbird General Technical Chat 9 10-23-2005 09:07 PM


All times are GMT -5. The time now is 05:17 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1