Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum

Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum (
-   Focus Tuning Chat (
-   -   SCT Xcal 3 filesystem ERROR needs to be reloaded (

BowerR64 11-15-2011 11:07 PM

SCT Xcal 3 filesystem ERROR needs to be reloaded
I got a new Asus EeePC and i planned to use this as my dataloging PC so i installed Livelink and the SCT updater.

After i installed everything it found an update and warned me to return my car to stock first. After a few tries it loaded back to stock. Then i updated the handheld then it crashed.

Now it just says

When i ran the updater it seem to update the SCT updater then went right into the firmware update.

Since ive owned this unit ive updated the handheld device 2 times. Both times i had to hold the cancel button down when i plugged it in and put it into the firmware update mode. This time it just kinda helped itself to the update and fubard the update. I tried to redo the firmware doing it the old way holding cancel and putting it into the firmware update mode but it doesnt seem to be working.

The update program goes threw the "erasing" then "writing" but then when it gets to the part it says to unplug it it reboots and throws that error screen.

The first 2 firmware updates i used on an XP laptop, this one has windows 7 could that be the issue?

I did put my car back to the stock ECU file but i know its going to run like crap and i dont even want to try and drive it with the stock file.

Only reason i plugged the handheld in was to see if it needed a firmware update. I didnt think it was updating yet, i thought the SCT updater was. I didnt think the handheld would allow it to erase or write to the handheld WITHOUT being in the firmware update mode which you do when you hold the cancel button down while you plug it in.

The handheld i would think should lock out any updating unless its in the firmware update mode where you hold the cancel button down while plugging it in. Just for safty.

BowerR64 11-16-2011 12:36 AM

Cool i figured it out. I noticed the file it wanted to update had a ".LWU" file extension i searched and found another .LWU file on the machine in the C:\Program Files\SCT\SCT Device Updater. This file appears older i think 7/11/2011 or something like that.

So i did the old style update holding the cancel button while i plugged it in and this time updated it using the older .LWU file.

It loaded fine. Then i ran the "scan for updates" again this time on the XP laptop and it found an updated firmware and it updated smooth this time.

Weird this time it did a "low level format" dont remember seing that before on previous firmware updates. Maybe because it was a bad update last time so it just wiped it clear and started over?

Im skeered now to hook it to my car and put the last tune file back in and brick my car. [bigcry]

Least i didnt have to call and bug SCT, just had to think about it a bit. Must of had a corrupt newer .LWU file or something?

1turbofocus 11-16-2011 09:34 AM

Best thing to do is , If everything is working ok DO NOT UPDATE

This goes for everyone , the updates are to fix things that are not working correctly if you can datalog and load tuned I wouldnt update anything ever


BowerR64 11-16-2011 10:05 AM

If it aint broke dont fix it?

Thats my problem, im always trying to make it better till it does break.

It took me a while to figure out this whole sct system but ide still say its a pretty flawless system.

Ive flashed the car like 15 times now with no issues.

A few hickups here and there aint bad.

BowerR64 11-16-2011 12:37 PM

Well i spoke to soon, it wont load the last tune file.

I think i might have to call em now...

I plug it in and select custom tune
pick the last tune file i was running
keep changes
begin to upload
asks me to turn the key on dont start it

then it beeps and says: unlock ECM failed "ERROR 1019"

push select and it beeps again and says: upload stock failed "ERROR 1017"

push select again it beeps and says: no tune changes written "ERROR 1009"

Do i need to unlock the handheld again?

1turbofocus 11-16-2011 04:45 PM

I would contact SCT before you go further


BowerR64 11-16-2011 05:33 PM

I did and they wernt really much help. I kept at it and finally got it updated and got a file loaded.

I wont be doing any more updates though i didnt like that. [rolleyes]

BowerR64 11-23-2011 03:11 PM

Readjusted some things on it last night, held my breath the whole time.

I did the updates at the ford service parking lot, just incase i would save myself a tow bill. [facepalm]

Everything worked out so far though. wheeeew

All times are GMT -5. The time now is 01:29 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.