Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum

Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum (
-   Focus Tuning Chat (
-   -   I messed up my xcal :( help please! (

drostedrummer89 10-21-2011 11:07 PM

I messed up my xcal :( help please!
So I picked up an unlocked xcal3 tonight, and I was updating it via the sct software from their site. I was sending an updated file to the device, and the computer stopped responding, and I was forced to close the sct updater. when I looked at the device, it still said DO NOT UNPLUG DEVICE.

...I unplugged it. now it wont recognize the device, and the only thing that its doing is lighting up the backlit display. nothing else works. I'm guessing I have to reinstall the firmware, but how do I do that if it wont connect to my computer

Any help is greatly appreciated.


FocusedSlayer 10-22-2011 05:11 AM

I know when I updated my Firmware without returning my Focus to the stock tune and tried it on my car I wiped out the ECU and had to have the Sct tuner sent back to get it restored and updated like it needed to be . And then I had to have my car towed to the dealership and have it reflashed to stock . :(

drostedrummer89 10-22-2011 07:46 AM

That sucks, at least my car was still stock. I bet sct is going to have me send it in too. How much was that?

Posted via FF Mobile

FocusedSlayer 10-22-2011 12:31 PM

Posted via FF Mobile I think it was around 15.00 but if you talk to a tech on the phone, he might be able to fix it by connecting to your computer and you having the tuner plugged in. They tried that on mine before I had to send it back.

drostedrummer89 10-23-2011 07:58 PM

15 isnt bad, thanks for the info!

Posted via FF Mobile

drostedrummer89 10-25-2011 02:33 PM

tech support fixed it, just reformatted and reinstalled firmware [thumb]


bespurcell 10-25-2011 04:53 PM

Good to hear.

BowerR64 10-31-2011 01:48 PM

I had something scary happen to me the other day.

Doing the tune there are 3 part of software, well actually 2 software 1 FIRMWARE lately my livelink has been saying there is an update but then it errors and says it cant update. Then i went to add a new tune Tom sent me and the device updater says it has an update. Before i do that update i return my car to stock.

Then i update the device updater software. For some reason i thought the handheld device was ready to update so i put it into update mode but then there is no updated firmware file so the handheld didnt actually need updating just the software for the handheld.

I take the handheld out of update mode and then transfer in the new tune. When i go to update the tune it asks me to agree this is an advanced thing im doing do i agree to terms? It hasnt asked me that since the very first time i ever used it. Im thinking maybe Tom sent me a "super" tune file.

It does the memory check, updates the new tune, then loops around and does the memory check thing again and updates the tune a SECOND time. Im thinking its stuck in some loop and im going to have to unplug it.

After the second tune update "do not unplug" part it finishes and plays the happy tune that its complete.

That was a scary update let me tell ya.

why it checked memory and updated the tune file twice i dont know, but its never done it before.

Im glad it all worked out though.

All times are GMT -5. The time now is 08:59 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.