xcal 3..Value cannot be null - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > Focus Tuning Chat

Focus Tuning Chat Discuss performance tuning options for your Ford Focus.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Reply




 
LinkBack Thread Tools Display Modes
Old 04-05-2010, 07:21 PM   #1
Focus Enthusiast
 
StreetFocusZX3's Avatar
 
Join Date: May 2007
Fan#: 47579
Location: Frankfort, IL
What I Drive: 2006 Sonic Blue ZX3 W/ Sap

Posts: 371
FF Reputation: 1 StreetFocusZX3 Good Standing Member
Buy-Sell-Trade Rating: (8)
xcal 3..Value cannot be null

What the hell does that mean? Anyone ever see this error code when trying to link your xcal3 to your computer. Now i cant even load or update anything because i cant get it to link to my computer. Help to anyone


__________________
2006 Sonic Blue ZX3 w/Sap
2002 Black Lightning(Boosted)
1998 Ford F150 Nascar Edition(Sold)
1995 Ford Bronco XLT(Sold)
StreetFocusZX3 is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-05-2010, 07:52 PM   #2
LETS TURN DIRT!!!!
 
03OrangeSVT's Avatar
 
Join Date: Feb 2005
Fan#: 19169
Location: Piketon, OH
What I Drive: MINI Cooper S TURBO

Posts: 11,906
FF Reputation: 152 03OrangeSVT Excellent Standing Member 03OrangeSVT Excellent Standing Member
Buy-Sell-Trade Rating: (5)
Wow... this makes me glad that I stayed with the Xcal2.

You have had nothing but trouble with this thing......

Maybe get an exchange or a refund or trade in for and X2??
__________________
[B]1951 McCormick FARMALL M
2007 MINI Cooper S Turbo... new project car
1998 Chevy 3500 Ext cab, long bed, 4x4, duelly, turbo diesel
2004 Harley V-Rod.... sex on wheels
2011 Harley Electra Glide Ultra Limited
[/b]
03OrangeSVT is offline  
    Reply With Quote Quick reply to this message
Old 04-05-2010, 07:55 PM   #3
Focus Enthusiast
 
bigdesignmachine's Avatar
 
Join Date: Mar 2010
Fan#: 73457
Location: Leander, TX
What I Drive: 2013 Tuxedo Black ST2

Posts: 196
FF Reputation: 1 bigdesignmachine Good Standing Member
Buy-Sell-Trade Rating: (3)
I would talk to SCT support.

http://www.sctflash.com/tech.php
__________________
:
:
:

D R E A M S P E E D
bigdesignmachine is offline  
    Reply With Quote Quick reply to this message
Old 04-05-2010, 09:18 PM   #4
Focus Enthusiast
 
StreetFocusZX3's Avatar
 
Join Date: May 2007
Fan#: 47579
Location: Frankfort, IL
What I Drive: 2006 Sonic Blue ZX3 W/ Sap

Posts: 371
FF Reputation: 1 StreetFocusZX3 Good Standing Member
Buy-Sell-Trade Rating: (8)
03 orange you have no idea. Nothing but problems. SCT says they have a fix for it not tuning my ride at all, but they arent going to release it? So they told me to pull a fuse and after a couple of trys i got it to load. Now i cant get the damn thing to link to either my laptop or my desktop.

Bigdesign, lol i tried to call sct support today and was on hold for 20 minutes plus. I put it on speaker phone and got some things done before i gave up. So i just wondered if anyone else had this issue. I've had nothing but problems with this thing. They said its only 05-07 focus's of coarse. I'm shootin in the breeze now.
__________________
2006 Sonic Blue ZX3 w/Sap
2002 Black Lightning(Boosted)
1998 Ford F150 Nascar Edition(Sold)
1995 Ford Bronco XLT(Sold)
StreetFocusZX3 is offline  
    Reply With Quote Quick reply to this message
Old 04-06-2010, 06:32 AM   #5
Focus Addict
 
Blivit's Avatar
 
Join Date: Nov 2007
Fan#: 51292
Location: Sanford, FL
What I Drive: 2013 ST

Posts: 720
Points 2,359, Level 29
Points: 2,359, Level: 29 Points: 2,359, Level: 29 Points: 2,359, Level: 29
Level Up 40% Completed
Level up: 40% Level up: 40% Level up: 40%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 118 Blivit Excellent Standing Member Blivit Excellent Standing Member
Buy-Sell-Trade Rating: (2)
Quote:
Originally Posted by StreetFocusZX3 View Post
03 orange you have no idea. Nothing but problems. SCT says they have a fix for it not tuning my ride at all, but they arent going to release it? So they told me to pull a fuse and after a couple of trys i got it to load. Now i cant get the damn thing to link to either my laptop or my desktop.

Bigdesign, lol i tried to call sct support today and was on hold for 20 minutes plus. I put it on speaker phone and got some things done before i gave up. So i just wondered if anyone else had this issue. I've had nothing but problems with this thing. They said its only 05-07 focus's of coarse. I'm shootin in the breeze now.
Please re-read what I wrote in my PM to you. At no point did I say the firmware would not be released. I stated "I haven't released the firmware yet because it hasn't gone all the way through testing yet." Which means once it has gone through final testing it would be released. I mentioned we typically do not release firmware for a single issue but I still made no remarks that the fix would not be released.

I am not on the phones and I have no control over the wait times.

You have a problem yet you do not post any details so lets start there. What operating system is on your computer? What firmware is on your X3 and what version of livelink are you using? At what point does the error come up? Do you have any other SCT programs open and running when the error comes up?

To check your driver, with the X3 connected to your pc go into device manager and look for "jungo." Expand that and "x3pdevice" should be listed there along with "windriver." If they are not, you need to reinstall the driver. The quickest and easiest way to do that would be to close all SCT programs, and install the updater program from our website (uninstall it first if you already have it installed.)
Blivit is offline  
    Reply With Quote Quick reply to this message
Old 04-06-2010, 06:45 AM   #6
Focus Enthusiast
 
StreetFocusZX3's Avatar
 
Join Date: May 2007
Fan#: 47579
Location: Frankfort, IL
What I Drive: 2006 Sonic Blue ZX3 W/ Sap

Posts: 371
FF Reputation: 1 StreetFocusZX3 Good Standing Member
Buy-Sell-Trade Rating: (8)
Blivit, i apologize for jumping the gun on you. I now understand that you have no control over things that involve a single problem. I've just been frusturated because i've had this thing for over a year and havent had anything but problems with it. When i hear the word of a "fix" i get excited. Even pulling the fuse it gives me problems. It takes at least 2 trys and even a blow in the obdII port before it wants to do anything.

I wanted to load up a tune revision from Tom to my x3. I plug the x3 in while holding cancel like your suppose to do. All i tried to do was click on Display Device Setting and Serial Number and that error code pops up. It has to be the drivers because when i plug the unit it in, it does not recongnize that it's even been plugged in.

FW Version 1. 2. 121
Tune Version 1 . 2. 1
Device Unmarried
__________________
2006 Sonic Blue ZX3 w/Sap
2002 Black Lightning(Boosted)
1998 Ford F150 Nascar Edition(Sold)
1995 Ford Bronco XLT(Sold)
StreetFocusZX3 is offline  
    Reply With Quote Quick reply to this message
Old 04-06-2010, 07:21 AM   #7
Focus Addict
 
Blivit's Avatar
 
Join Date: Nov 2007
Fan#: 51292
Location: Sanford, FL
What I Drive: 2013 ST

Posts: 720
Points 2,359, Level 29
Points: 2,359, Level: 29 Points: 2,359, Level: 29 Points: 2,359, Level: 29
Level Up 40% Completed
Level up: 40% Level up: 40% Level up: 40%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 118 Blivit Excellent Standing Member Blivit Excellent Standing Member
Buy-Sell-Trade Rating: (2)
Quote:
Originally Posted by StreetFocusZX3 View Post
I plug the x3 in while holding cancel like your suppose to do.
This is your problem. If you are trying to load in a custom tune file (.cef) from Tom, you do not need to hold the cancel button down. Plug the device in normally and select the "load custom tune" button.
Blivit is offline  
    Reply With Quote Quick reply to this message
Old 04-06-2010, 10:38 PM   #8
Focus Enthusiast
 
StreetFocusZX3's Avatar
 
Join Date: May 2007
Fan#: 47579
Location: Frankfort, IL
What I Drive: 2006 Sonic Blue ZX3 W/ Sap

Posts: 371
FF Reputation: 1 StreetFocusZX3 Good Standing Member
Buy-Sell-Trade Rating: (8)
When is it that i have to hold cancel and plug it in? Updating firmware?
__________________
2006 Sonic Blue ZX3 w/Sap
2002 Black Lightning(Boosted)
1998 Ford F150 Nascar Edition(Sold)
1995 Ford Bronco XLT(Sold)
StreetFocusZX3 is offline  
    Reply With Quote Quick reply to this message
Old 04-07-2010, 12:04 AM   #9
Focus Fanatic
 
PSUrivie's Avatar
 
Join Date: Jul 2009
Fan#: 67329
Location: Elkridge, MD
What I Drive: Boostin in the Mid-A

Posts: 2,080
Points 7,276, Level 56
Points: 7,276, Level: 56 Points: 7,276, Level: 56 Points: 7,276, Level: 56
Level Up 63% Completed
Level up: 63% Level up: 63% Level up: 63%
Forum Activity 4%
Activity: 4% Activity: 4% Activity: 4%
FF Reputation: 15 PSUrivie Great Standing Member
Buy-Sell-Trade Rating: (10)
yeah that's when you update the device. Plug it in and then choose custom tune. Pick which ever tune you want to load and the xcal will prompt you to turn the key ON
__________________
FSWerks stg2 w/ water/meth; Cossie intake.
PSUrivie is offline  
    Reply With Quote Quick reply to this message
Old 04-07-2010, 06:39 AM   #10
Focus Addict
 
Blivit's Avatar
 
Join Date: Nov 2007
Fan#: 51292
Location: Sanford, FL
What I Drive: 2013 ST

Posts: 720
Points 2,359, Level 29
Points: 2,359, Level: 29 Points: 2,359, Level: 29 Points: 2,359, Level: 29
Level Up 40% Completed
Level up: 40% Level up: 40% Level up: 40%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 118 Blivit Excellent Standing Member Blivit Excellent Standing Member
Buy-Sell-Trade Rating: (2)
Quote:
Originally Posted by StreetFocusZX3 View Post
When is it that i have to hold cancel and plug it in? Updating firmware?
Correct. The only time you need to hold cancel is when updating firmware.
Blivit is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:01 PM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1