Sluggish performance - Page 2 - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Third Generation > DURATEC Ti-VCT Performance (2012-Current)

DURATEC Ti-VCT Performance (2012-Current) The place to chat about any Duratec 2.0L Ti-VCT engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Reply




 
LinkBack Thread Tools Display Modes
Old 08-05-2013, 07:54 PM   #11
Focus Rookie
 
comcast.net's Avatar
 
Join Date: Jul 2013
Fan#: 117212
Location: Williston, VT
What I Drive: 2013 Performance Blue 5Spd SE HB

Posts: 7
FF Reputation: 1 comcast.net Good Standing Member
Buy-Sell-Trade Rating: (0)
You might want to disconnect the battery and "reboot" your car...Back in the day when I had a 1995 Mercury Mystique with the Duratec 2.5 V6/5spd combo, if I made any changes to the car like intake/exhaust, I would in essence wipe the ECU to create a new map...I wonder if that's relevant today.
comcast.net is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-05-2013, 08:51 PM   #12
Focus Rookie
 
Join Date: Aug 2013
Fan#: 117474
Location: Berkley, MI
What I Drive: 2012 Sterling Grey Metallic SE

Posts: 10
FF Reputation: 1 Timkainu Good Standing Member
Buy-Sell-Trade Rating: (0)
I did disconnect the negative battery and "reset" the ECU, twice I think? First time when I installed the CAI, second time a week later for the heck of it.

I brought the car into the shop a month ago because the check engine light came on, and the car bogged down. Apparently it was something with the transmission that threw the car into limp mode. The shop reset the codes, and made the car go through a "relearning process" but he said there's still a chance the light may come back on.

But, I guess there's a TSB for it, the shop said. The DTC code was P2837. So, in the instance the problem happens again, they said to bring my car to the dealer and give this TSB report to them so they can reprogram my car.

Anyways, I hope this tuner helps me out. The car does seem to run rich or something. Definitely not how my girlfriends car runs.

Thanks again for all the help, guys!
Timkainu is offline  
    Reply With Quote Quick reply to this message
Old 08-10-2013, 03:44 AM   #13
Focus Addict
 
MG_MK3's Avatar
 
Join Date: May 2013
Fan#: 114522
Location: Pittsburgh, PA
What I Drive: 2013 Blue Candy Focus Hatchback SE

Posts: 594
Points 528, Level 10
Points: 528, Level: 10 Points: 528, Level: 10 Points: 528, Level: 10
Level Up 56% Completed
Level up: 56% Level up: 56% Level up: 56%
Forum Activity 9%
Activity: 9% Activity: 9% Activity: 9%
FF Reputation: 0 MG_MK3 Newbie
Buy-Sell-Trade Rating: (1)
Quote:
Originally Posted by Timkainu View Post
I did disconnect the negative battery and "reset" the ECU, twice I think? First time when I installed the CAI, second time a week later for the heck of it.

I brought the car into the shop a month ago because the check engine light came on, and the car bogged down. Apparently it was something with the transmission that threw the car into limp mode. The shop reset the codes, and made the car go through a "relearning process" but he said there's still a chance the light may come back on.

But, I guess there's a TSB for it, the shop said. The DTC code was P2837. So, in the instance the problem happens again, they said to bring my car to the dealer and give this TSB report to them so they can reprogram my car.

Anyways, I hope this tuner helps me out. The car does seem to run rich or something. Definitely not how my girlfriends car runs.

Thanks again for all the help, guys!

Very odd....
__________________
@miKeyGilmore #MK3SLöCUS
I'm bagged, and not an ST.
MG_MK3 is offline  
    Reply With Quote Quick reply to this message
Old 08-10-2013, 06:11 AM   #14
Focus Addict
 
Join Date: Feb 2011
Fan#: 83279
Location: Roswell, GA
What I Drive: 2014 Ruby Red Titanium Hatch

Posts: 678
Points 3,228, Level 35
Points: 3,228, Level: 35 Points: 3,228, Level: 35 Points: 3,228, Level: 35
Level Up 19% Completed
Level up: 19% Level up: 19% Level up: 19%
Forum Activity 12%
Activity: 12% Activity: 12% Activity: 12%
FF Reputation: 3 roswelltop Good Standing Member
Buy-Sell-Trade Rating: (0)
My 2 cents on this, call Aron at Injected Engineering and talk through the issues that you're having with your car. I have the IE tune and am totally happy with the result, BUT my car was running perfectly (I.e. OEM style with the K&N CAI) before the tune was installed.

Here's the thing, and maybe my thinking is wrong, if there is something wrong with your car now AND the tune doesn't correct it, you are going to be even unhappier.

Hope you get your car running right because this engine just performs so beautifully.
Good luck.
roswelltop is offline  
    Reply With Quote Quick reply to this message
Old 08-10-2013, 08:16 AM   #15
Focus Addict
 
Juicedz's Avatar
 
Join Date: Jan 2013
Fan#: 108814
Location: Fort Myers, FL
What I Drive: 2013 Ford Focus Hatchback SE, 5sp

Posts: 1,323
Points 2,491, Level 30
Points: 2,491, Level: 30 Points: 2,491, Level: 30 Points: 2,491, Level: 30
Level Up 28% Completed
Level up: 28% Level up: 28% Level up: 28%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 3 Juicedz Good Standing Member
Buy-Sell-Trade Rating: (1)
Ordering the tune was a great choice. However, take the car in to have the current tsb done to it (software update & strut bearings). Are both of your cars automatics?
__________________
'13 Oxford White Hatch 5-speed
injected 93 tune, steeda intake, e-focus rmm
Hatch Nation#24 172whp 157wtq
Juicedz is offline  
    Reply With Quote Quick reply to this message
Old 08-10-2013, 04:21 PM   #16
Focus Rookie
 
Join Date: Aug 2013
Fan#: 117474
Location: Berkley, MI
What I Drive: 2012 Sterling Grey Metallic SE

Posts: 10
FF Reputation: 1 Timkainu Good Standing Member
Buy-Sell-Trade Rating: (0)
Yeah, I wish I could bring it in and have the TSB applied to it. However, the Ford dealer I called up said I would have to wait until the light came on again to apply it. Is there a way I can have them do it without waiting for the light?

And thanks for the suggestions. I will call Aron and see what he has to say. I just tuned my car with the 93 octane tune and it seems a little better. Still doesn't seem as quick as my girlfriends. We both have automatics.

I always used 87 octane. Just recently went through my first full tank of 93. Would unplugging the negative wire from the battery again do any good, or would it be useless? Should it be done after a tune?

Thanks again for all the help, everyone.
Timkainu is offline  
    Reply With Quote Quick reply to this message
Old 08-10-2013, 04:34 PM   #17
Focus Enthusiast
 
Join Date: Jul 2013
Fan#: 117201
Location: Saint john, Canada
What I Drive: 2013 tuxedo black se

Posts: 99
Points 602, Level 12
Points: 602, Level: 12 Points: 602, Level: 12 Points: 602, Level: 12
Level Up 4% Completed
Level up: 4% Level up: 4% Level up: 4%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 Irondemon Good Standing Member
Buy-Sell-Trade Rating: (0)
Just a thought, do both cars have the same size wheels/tires and are bothe optioned the same? Just trying to help narrow it down.
(Edit) just reread one has the sport package and one doesn't.
__________________
2013 tuxedo black se hatch. Tinted, smoked,custom xcal tune, steeda cai,magnaflow catback,header, 18"black ford racing wheels, eibach pro kit springs,steeda front and rear sway bar, motor mounts, red badge overlays.

Last edited by Irondemon; 08-10-2013 at 04:38 PM. Reason: Smrt like dumptruck
Irondemon is offline  
    Reply With Quote Quick reply to this message
Old 08-10-2013, 07:45 PM   #18
Focus Rookie
 
Join Date: Aug 2013
Fan#: 117474
Location: Berkley, MI
What I Drive: 2012 Sterling Grey Metallic SE

Posts: 10
FF Reputation: 1 Timkainu Good Standing Member
Buy-Sell-Trade Rating: (0)
Yes, she has the sport package. We both have the same size wheels and tires. Hers is flex fuel compatible.

Wish I knew what it was. I'm still wondering why the spark plugs look like they do. Perhaps it's normal.

I observed where my car is slower. It's around 1300-1500 RPM and around 25-35 MPH. If I stomp on the throttle, it's sluggish to get to 45-50. That's where it seems like I get sluggish performance.
Timkainu is offline  
    Reply With Quote Quick reply to this message
Old 08-11-2013, 08:11 AM   #19
Ford Fiend
 
TboneZX3's Avatar
 
Join Date: Oct 2011
Fan#: 90494
Location: Jackson, MO
What I Drive: '12 SE Sport, '01 ZX3, '67 Bronco

Posts: 2,179
Points 1,286, Level 19
Points: 1,286, Level: 19 Points: 1,286, Level: 19 Points: 1,286, Level: 19
Level Up 86% Completed
Level up: 86% Level up: 86% Level up: 86%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 10 TboneZX3 Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Timkainu View Post
Wish I knew what it was. I'm still wondering why the spark plugs look like they
That spark plug looks perfectly normal to me. You're always going to have a light carbon film as a by-product of combustion. If it was thick and crusty, there would be reason for concern.
__________________
Hatch Nation #90
'12 SE Sport 5Dr |╠╬╝|Sterling Grey Metallic|203a|Moonroof|17" Paint/Mach Whls|K&N 57S-4000|FFE RMM|Steeda STB, RSB|JBR bushings
'01 ZX3|╠╬╝|Pitch Black|Prem. pkg.|Moonroof|SVT Snorkel|SVT Springs|S2 Dampers|Steeda STS|Magnaflow exh.
TboneZX3 is offline  
    Reply With Quote Quick reply to this message
Old 08-11-2013, 08:51 PM   #20
Focus Enthusiast
 
VonKaiser's Avatar
 
Join Date: Aug 2005
Fan#: 26749
Location: Little Elm, TX
What I Drive: 2013 Ford Focus SE sedan

Posts: 470
FF Reputation: 1 VonKaiser Good Standing Member
Buy-Sell-Trade Rating: (0)
Anyone got a YouTube video of the off the line acceleration with the Injected tune for us DCT automated manual owners?
__________________
2013 Ford Focus SE Sedan
2012 Ford Fusion SE I4
1990 Chevrolet Camaro RS V8 [sold]
VonKaiser is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 11:11 PM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1