amp/speakers or new HU - Page 2 - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > Car Audio, SYNC, MyFord Touch & Electronics

Car Audio, SYNC, MyFord Touch & Electronics The Forum for the Ford Focus audiophiles. The place to chat about automobile sound systems, security systems, or show off your I.C.E.!
Sponsored By: GT Sound Control


Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Reply




 
LinkBack Thread Tools Display Modes
Old 12-05-2012, 08:10 PM   #11
Focus Enthusiast
 
Join Date: Apr 2011
Fan#: 85098
Location: Hallettsville, TX, TX
What I Drive: 2002 Black ZX5

Posts: 262
Points 2,698, Level 31
Points: 2,698, Level: 31 Points: 2,698, Level: 31 Points: 2,698, Level: 31
Level Up 66% Completed
Level up: 66% Level up: 66% Level up: 66%
Forum Activity 1%
Activity: 1% Activity: 1% Activity: 1%
FF Reputation: 3 austinpetemo Good Standing Member
Buy-Sell-Trade Rating: (0)
Ok so when I pulled the head unit forward I accidentally pulled out a connection in the back. Redid everything and it came on. Up next will be a better HU and thicker power/ground. I'm thinking 2awg to a distributor and then 4awg to each amp will work. When I get a better sub amp I still won't be running more 600w through it. I think what I have right now is like 6-8 and prolly not true copper. I made sure to get true 14awg 99.9% copper wire for my components but I just used power cable I already had installed.
austinpetemo is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-05-2012, 10:10 PM   #12
Vince your Moderator
 
freemind's Avatar
 
Join Date: Jul 2009
Fan#: 67513
Location: Seattle, WA
What I Drive: 2002 ZX3 and a 2010 Focus SE (Work)

Posts: 5,042
Points 7,219, Level 56
Points: 7,219, Level: 56 Points: 7,219, Level: 56 Points: 7,219, Level: 56
Level Up 35% Completed
Level up: 35% Level up: 35% Level up: 35%
Forum Activity 6%
Activity: 6% Activity: 6% Activity: 6%
FF Reputation: 24 freemind Great Standing Member
Buy-Sell-Trade Rating: (23)
Quote:
Originally Posted by austinpetemo View Post
Ok so when I pulled the head unit forward I accidentally pulled out a connection in the back. Redid everything and it came on. Up next will be a better HU and thicker power/ground. I'm thinking 2awg to a distributor and then 4awg to each amp will work. When I get a better sub amp I still won't be running more 600w through it. I think what I have right now is like 6-8 and prolly not true copper. I made sure to get true 14awg 99.9% copper wire for my components but I just used power cable I already had installed.
You cannot go wrong here, http://www.knukonceptz.com/

Easy on the wallet as well
__________________
133whp-126ftlbsTQ Eclipse CD8443,Eclipse PA5422, JBL GTO751EZ, PPI 356cs(Rebranded A/D/S 346cs), JBL p1024, SubThump enclosure, RAAmat BXT, Damplifier Pro

Hatch Nation #140
Caeci caecos ducentes
freemind is offline  
    Reply With Quote Quick reply to this message
Old 12-10-2012, 05:10 AM   #13
Focus Enthusiast
 
Join Date: Apr 2011
Fan#: 85098
Location: Hallettsville, TX, TX
What I Drive: 2002 Black ZX5

Posts: 262
Points 2,698, Level 31
Points: 2,698, Level: 31 Points: 2,698, Level: 31 Points: 2,698, Level: 31
Level Up 66% Completed
Level up: 66% Level up: 66% Level up: 66%
Forum Activity 1%
Activity: 1% Activity: 1% Activity: 1%
FF Reputation: 3 austinpetemo Good Standing Member
Buy-Sell-Trade Rating: (0)
Ive been noticing alot of alternator whine. Is this due to the small power cable that is currently being used? I tried putting a bigger ground cable to the HU to see if maybe by some chance it would help but no dice. would the big 3 fix this?
austinpetemo is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Pitch Black ZX3
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:58 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1