Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - experience Needed transmission, throttle body, troubles? (This is long)
View Single Post
Old 03-31-2013, 10:44 AM   #11
whynotthinkwhynot
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 Focus Wagon; 13 C-Max SEL

Posts: 20,347
Points 28,348, Level 98
Points: 28,348, Level: 98 Points: 28,348, Level: 98 Points: 28,348, Level: 98
Level Up 99% Completed
Level up: 99% Level up: 99% Level up: 99%
Forum Activity 3%
Activity: 3% Activity: 3% Activity: 3%
FF Reputation: 271 whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
Have you checked to see what DTCs are appearing- if any? Perhaps the problem is not the transmission, but just seems to be. Maybe the reason it is surging without power once you come to a stop the first time is because the idle is simply not high enough. Your symptoms are typical TPS symptoms. I doubt that a TBS of 69k or 34k miles would be bad, but it certainly isn't unheard of. Can you verify that the part is a factory part, and what that factory part number is. It seems strange that your engine was swapped without swapping the transmission at the same time. IMO it would've been worth the shop's time to swap both from a wrecked vehicle, then sell trans from the car whether the customer wanted to pay extra for it or not. It would certainly save labor to remove both as a single unit. Then again, I've been wondering WTF most people are thinking these days anyway- stupidity seems globally rampant. Another explanation is that the donor vehicle was a MT, and if that is the case, then the TB would have to be swapped from the old engine or it wouldn't hook up to the AT. Have you verified that you have an AT TB installed? On an 09, it should have 2 cables attached- one for Cruise, and one for the kickdown linkage.

OH crap, that reminds me..... you have the freaking electric TB. Your TB could be the problem. We have seen that several times and it is more likely to happen earlier on in the car's life.
__________________
Be eclectic.
---The Complete How-To Archive--

Moderating everything now, let me know if I can help.

Quote:
Originally Posted by the user formerly known as ZX3_Chick View Post
You're special aren't you.
whynotthinkwhynot is offline  
    Reply With Quote