Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - factory or aftermarket?
View Single Post
Old 01-24-2013, 01:05 AM   #10
sleepyboy
FF's Night Security
 
sleepyboy's Avatar
 
Join Date: Nov 2004
Fan#: 15335
Location: SW Houston, TX, United States
What I Drive: 01' Yellow ZX3 euro, 04' ZX5 SVT

Posts: 28,678
Points 158,006, Level 100
Points: 158,006, Level: 100 Points: 158,006, Level: 100 Points: 158,006, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 8%
Activity: 8% Activity: 8% Activity: 8%
FF Reputation: 51 sleepyboy Excellent Standing Member
Buy-Sell-Trade Rating: (11)
The ES mount has a lip on it to keep the mount from slipping out of the dog bone. I've also had a new Prothane mount split on me before which caused some damage to my car. Now I have a leaking PS rack and a bent exhaust. Though the exhaust was a tad too close to my PS rack to begin with but when the mount gave it whacked it good. I've had the ES mount last years before failing. Poly mounts do wear out they just take a lot longer to do it. Oh and the other Prothane mount I had is slipping out the mount. You can order the ES mount directly from ES for less than 25 bucks shipped. I have pics but can't post them due to my work internet.
__________________
I started out with nothing and I still have most of it left

Hatch Nation #15 (Ole' Yeller') & #150 (The SVT)
Moderator for

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
sleepyboy is online now  
    Reply With Quote