Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - Restart issue after timing belt replacement
View Single Post
Old 01-19-2013, 03:18 PM   #6
mikebontoft
Aurelius Pardus
 
mikebontoft's Avatar
 
Join Date: Aug 2008
Fan#: 58647
Location: SLC, UT
What I Drive: 5.9L Grand Cherokee ZJ

Posts: 26,534
Points 24,482, Level 95
Points: 24,482, Level: 95 Points: 24,482, Level: 95 Points: 24,482, Level: 95
Level Up 14% Completed
Level up: 14% Level up: 14% Level up: 14%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 76 mikebontoft Excellent Standing Member
Buy-Sell-Trade Rating: (3)
Well, you know the timing is set right. Put the rest of it back together. you need to bleed the cooling system anyway.

Can you physically hear the pump operating?

That's correct though, there is no pressure test fitting. The little "regulator" you see on the end of the rail is simply a pressure sensor so the computer can adjust the pump's output.

Also, are you sure someone didn't siphon out the gas?
__________________
SR #127 | '02 Focus SE "Foci" (5.0 RWD - parted) | '75 BMW 2002 "Carby" (racecar) | '98 Jeep Grand Cherokee 5.9L (lifted and fast) | '99 BMW 328is (daily).
Moderating
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
mikebontoft is offline  
    Reply With Quote