Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - wierd problem, please help
View Single Post
Old 12-09-2012, 08:34 PM   #3
whynotthinkwhynot
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 Focus Wagon; 13 C-Max SEL

Posts: 21,044
Points 32,638, Level 100
Points: 32,638, Level: 100 Points: 32,638, Level: 100 Points: 32,638, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 42%
Activity: 42% Activity: 42% Activity: 42%
FF Reputation: 274 whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
UH, typically running hot on the highway is a sign of a stuck thermostat- regardless of what they told you. Check the fluid level though. Sometimes these new systems are harder to fill than you think, so make sure you have enough coolant in there. Make sure you put the right kind of coolant in there if you add some. You'll have either gold or red, unless they cheaped you out with green. Whatever it is, it's never right to use Dexcool, and match the color if you have to add some.
__________________
Be eclectic.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Moderating everything now, let me know if I can help.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Quote:
You're special aren't you.
whynotthinkwhynot is offline  
    Reply With Quote