Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - 2013 engine "click click whir" (engine not running)
View Single Post
Old 11-13-2012, 03:12 PM   #16
Official Ford Rep
FordService's Avatar
Join Date: Oct 2010
Fan#: 79824
Location: Dearborn, MI
What I Drive: Ford Focus

Posts: 5,444
Points 4,202, Level 41
Points: 4,202, Level: 41 Points: 4,202, Level: 41 Points: 4,202, Level: 41
Level Up 26% Completed
Level up: 26% Level up: 26% Level up: 26%
Forum Activity 79%
Activity: 79% Activity: 79% Activity: 79%
FF Reputation: 19 FordService Great Standing Member
Buy-Sell-Trade Rating: (0)
Originally Posted by recyclebin View Post
...Thanks again to everyone, and thanks to Crystal for the escalation offer - I may take you up on that in the future. I will post again to this thread when there is more information.
You're welcome, recyclebin. Feel free to contact me if you have any other questions or concerns. I'm always happy to see how I can help.

Originally Posted by HatsuneMiku View Post
I have this noise too. It was making that noise for 40 minutes when I was trying to learn how to use my ford touch yesterday. My car is very new, build date 10-12-12.
Hi HatsuneMiku,

If you're concerned, you should definitely make an appointment with your dealership so they can inspect. Ford certified techs are in the best position to diagnose and repair. Questions? Concerns? Send me a PM and I'll get you some answers.

Thanks everyone!

p: 800.392.FORD
t: @FordService @FordFocus @Ford

M - F 11 a.m. - 8 p.m. ET | Send a PM? Pls allow 2 business days for reply
FordService is offline  
    Reply With Quote