Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - Left Fog Bulb Blowing
View Single Post
Old 10-30-2012, 10:46 AM   #1
BetaDnB
Photog4Lyfe
 
BetaDnB's Avatar
 
Join Date: Jul 2011
Fan#: 87466
Location: Buffalo, NY
What I Drive: 2012 Silver SE Sport

Posts: 2,190
Points 2,576, Level 30
Points: 2,576, Level: 30 Points: 2,576, Level: 30 Points: 2,576, Level: 30
Level Up 84% Completed
Level up: 84% Level up: 84% Level up: 84%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 14 BetaDnB Great Standing Member
Buy-Sell-Trade Rating: (0)
Left Fog Bulb Blowing

I got my car in July '11. Sometime about a year ago I got a pair of Putco 3000k bulbs to put in there and saved the factory bulbs. The Putco on the left side went out in June or July this year. "Fine", I thought, knowing these aftermarket bulbs only have about a one year lifespan. So I replaced them with the factory bulbs I saved. This morning I discover again the left bulb is blown. I only have just over 17,000 miles on the car and I don't run my fogs all the time. I mainly use them as DRLs on long highway trips (or in fog/snow). Since they're the same power as the headlights and I haven't had a problem with them yet I think I may have an electrical issue going to this bulb. What's anybody else think? Anybody else have this problem?


__________________
Sedan Revolution #249 - 2012 SE Sport - ╠╬╝ - Ingot Silver - 201A - K&N w/ snorkel delete - Blox Type R Knob
BetaDnB is offline  
    Reply With Quote