Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - common problems with the Duratec?
View Single Post
Old 10-07-2012, 02:31 PM   #63
felixthecat
w/ my magic bag
 
felixthecat's Avatar
 
Join Date: Nov 2010
Fan#: 80663
Location: The Jet city, WA
What I Drive: '05 Silver Sport Technologies

Posts: 22,885
Points 24,866, Level 95
Points: 24,866, Level: 95 Points: 24,866, Level: 95 Points: 24,866, Level: 95
Level Up 52% Completed
Level up: 52% Level up: 52% Level up: 52%
Forum Activity 100%
Activity: 100% Activity: 100% Activity: 100%
FF Reputation: 80 felixthecat Excellent Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by WSkobra View Post
If you replace the passenger side mount just be careful when installing it. Don't poke the top with anything cause there is oil inside the passenger mount. I found out the hard way. The mount I keep having to replace is my upper trans mount. I have replaced it 6 times in the last 8 months. Of coursd I have the lower polyurethane bushing kit for my dog bone mount so that might have something to do with it.
6 times in last 8 months? What kind are you buying? oem's or e-bay specials? If anything that poly dogbone is helping it last longer. I'd replace it w/ a poly mount.
__________________
Introduce Mr. Torsen to the mix
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Bigger brakes then you- D23 crew- D-Tech- Sedan Revolution= #131
felixthecat is offline  
    Reply With Quote