Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - 02fordsvt Build/Mod/Random Thread
View Single Post
Old 10-03-2012, 02:40 PM   #943
02fordsvt's Avatar
Join Date: Apr 2011
Fan#: 84654
Location: Lowville, NY
What I Drive: 2002 SVT, 2004 Sport Trac

Posts: 10,253
Points 61,512, Level 100
Points: 61,512, Level: 100 Points: 61,512, Level: 100 Points: 61,512, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 16%
Activity: 16% Activity: 16% Activity: 16%
FF Reputation: 50 02fordsvt Excellent Standing Member
Buy-Sell-Trade Rating: (13)
Originally Posted by SvviftSVT View Post
Yeah, that's no good. Maybe from your back country driving?
Definitely a possibility, but for almost as long as I've owned this car, I've been sporadically getting a check engine light and code for that sensor so it may have been breaking for a long time. Furthermore, the sensor really shouldn't get damaged as long as the whole exhaust system isn't getting knocked backwards against the body. Another idea is that when I bought this car from the dealer, they removed the engine in order to replace the clutch so I'm wonder if in the process, the sensor may have gotten damaged while everything was getting moved around.

Regardless, I am hoping to build some skid plates for under the car someday.
Hatch Nation #13 : Rally Revolution #13 : ROTM Jan '13
It's Bryan, not Brian
RSVT-170 Build in Progress
Rusty is dead
02fordsvt is online now  
    Reply With Quote