Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - Problems with 2006 GHIA TDCI
View Single Post
Old 09-17-2012, 09:51 AM   #3
whynotthinkwhynot
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 Focus Wagon; 13 C-Max SEL

Posts: 20,960
Points 32,109, Level 100
Points: 32,109, Level: 100 Points: 32,109, Level: 100 Points: 32,109, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 46%
Activity: 46% Activity: 46% Activity: 46%
FF Reputation: 274 whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
It could be a leaking injector. Are you actually losing oil, or just assuming it's oil? How fast are you losing oil?

Also, I see where someone used vinyl electrical tape to rig up the oil breather- I'd definitely fix that with the proper part, then clean the area as best as I could with rags. If the engine will idle sufficiently, you can pressure wash an engine, but I always do it with it running so that if it cuts off while you're washing- you know where to look. Anyway, get it cleaned up, then you can more easily find if there is another leak. Usually really bad auto problems stem from more than one problem, so fix the obvious stuff first.
__________________
Be eclectic.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Moderating everything now, let me know if I can help.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Quote:
You're special aren't you.
whynotthinkwhynot is offline  
    Reply With Quote