Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - needing some help
View Single Post
Old 09-09-2012, 09:39 AM   #5
12 years strong
1sloho's Avatar
Join Date: Jun 2003
Fan#: 111
Location: VA. Beach, VA
What I Drive: '02 zx5

Posts: 6,882
Points 14,749, Level 78
Points: 14,749, Level: 78 Points: 14,749, Level: 78 Points: 14,749, Level: 78
Level Up 75% Completed
Level up: 75% Level up: 75% Level up: 75%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 17 1sloho Great Standing Member
Buy-Sell-Trade Rating: (3)
Originally Posted by mix1983 View Post
My HU has a reset button.. maybe look for that and hold it for a few seconds. That or I guess you could disconnect the battery for a while. Something got jolted and the HU went retarded, but I think it should be an easy fix.
tried that, no dice.
Originally Posted by mikebontoft View Post
check your under dash fuses. or check if the cigarette lighter works. I believe the two are tied together. I had what sounds like the same problem a long time ago. I remember then I couldn't get the thing to work but the eject button would, so I wired the two together. Then one day I found a bad fuse down there and it worked since.
ive checked all the fuses and they are all fine. maybe ill just pull all of em and check em. lol
Originally Posted by Now534 View Post
Try to pull plug out from the radio and see if a fuse is there its like that on my pioneer
already done it, and it was good.
1sloho is offline  
    Reply With Quote