Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - sporadic's Turbo Duratec build #2
View Single Post
Old 07-05-2012, 10:34 PM   #26
Focus Addict
sutyak's Avatar
Join Date: Sep 2004
Fan#: 12724
Location: Fairmont, WV
What I Drive: 06 Sonic Blue ZX5 SES turbo

Posts: 1,490
Points 14,408, Level 77
Points: 14,408, Level: 77 Points: 14,408, Level: 77 Points: 14,408, Level: 77
Level Up 90% Completed
Level up: 90% Level up: 90% Level up: 90%
Forum Activity 31%
Activity: 31% Activity: 31% Activity: 31%
FF Reputation: 62 sutyak Excellent Standing Member
Buy-Sell-Trade Rating: (15)
I believe I determined I have a 7.2psi spring in the wastegate. I had the spring out twice and I'm fairly certain it was green. HERE is the guide from Tial. I would have sworn the boost gauge didn't go above 6 though, but I guess I was trying to watch a lot of things a the same time.
I'm not sure if I'll go with the 8.7psi or the 10.1psi spring. Probably the 10.1psi...
EDIT: I believe the difference in boost readout is because I have my boost gauge referenced off the manifold and the wastegate gets its pressure off the compressor housing.

Installed photos:

Without manifold heat shield

With manifold heat shield (modified stock heat shield)

Sorry no decent under-car photos. I tried to take some tonight and it just didn't work out. Next time I'm under the car in the daylight I'll take some.

Overall I have to say I'm extremely happy with how smoothly the build went. I am also a firm believer in v-band clamps now!
I've only had it out for one drive to help dial in the tune, so I can't really comment yet on how fast the turbo spools etc. I should have more input after this weekend, and my also post data log info.
'04 Mach 1. Built. Turbo. 667whp/631wtq
'06 Focus. Built. Turbo. WMI. (sold)
'03 Mach 1 : 12.61 @ 106.59 (sold)
sutyak is offline  
    Reply With Quote