Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - New SVT...completley screwed (edit: not completely screwed anymore)
View Single Post
Old 03-23-2012, 09:09 AM   #66
p0sitivevibez
Focus Fanatic
 
p0sitivevibez's Avatar
 
Join Date: Aug 2004
Fan#: 11223
Location: Hanover, PA
What I Drive: 06 Civic Si coupe

Posts: 1,567
Points 6,775, Level 54
Points: 6,775, Level: 54 Points: 6,775, Level: 54 Points: 6,775, Level: 54
Level Up 13% Completed
Level up: 13% Level up: 13% Level up: 13%
Forum Activity 1%
Activity: 1% Activity: 1% Activity: 1%
FF Reputation: 1 p0sitivevibez Good Standing Member
Buy-Sell-Trade Rating: (6)
OK car is driving, but not great.

Compression test was good. But there is a burning clutch/rubber smell still that scares me. Fan resistor replaced and fans are working. Throttle sticking but not as bad as before. Sometimes it revs up in neutral. Almost died when I turned the AC on sitting at a stop light. I went to replace the PCV valve last night and the v-shaped hose was so brittle it broke off, so I need one of those. Was gonna take to my buddys shop this morning but can't with the PCV valve like that. Flex pipe is broken but I bought another off of here. There is a pretty remarkable loss of power. I think that might be the flex pipe broken, the bad front o2 sensor and maybe a vacuum leak. Clutch/brake fluid resvoir cap was broken, have another coming in.
__________________
A ZX3 and SVTF gone but not forgotten. Dark side complete, 06 Civic Si coupe.
p0sitivevibez is offline  
    Reply With Quote