Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - Focus 2012 Electrical Problems
View Single Post
Old 03-22-2012, 10:02 PM   #4
whynotthinkwhynot
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 Focus Wagon; 13 C-Max SEL

Posts: 20,960
Points 32,109, Level 100
Points: 32,109, Level: 100 Points: 32,109, Level: 100 Points: 32,109, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 46%
Activity: 46% Activity: 46% Activity: 46%
FF Reputation: 274 whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
Fritz is on Netflix.

Quick story: On the 05 Focus there are 2 small ground wires that connect to the chassis and the wiring harness from the negative battery terminal. Just one of those lost it's connection from a broken ring terminal. When I turned the key on- the wipers came on, even though the switch was off, there were lights in the dash, and the radio came on full blast.

Your problem is probably something simple like that.
__________________
Be eclectic.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Moderating everything now, let me know if I can help.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Quote:
You're special aren't you.
whynotthinkwhynot is offline  
    Reply With Quote