Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - 2012 Titanium Front Strut Low Speed Noise (Clunk/Rattle)
View Single Post
Old 03-21-2012, 01:29 PM   #59
FordService
Official Ford Rep
 
FordService's Avatar
 
Join Date: Oct 2010
Fan#: 79824
Location: Dearborn, MI
What I Drive: Ford Focus

Posts: 5,887
Points 8,341, Level 61
Points: 8,341, Level: 61 Points: 8,341, Level: 61 Points: 8,341, Level: 61
Level Up 64% Completed
Level up: 64% Level up: 64% Level up: 64%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 19 FordService Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by mastercko View Post
I have this same issue on my SEL...
Hi mastercko,

You can also send me a PM with the VIN, current mileage, personal and dealer contact. I'll escalate the concern to the Customer Service Mangager in your area.

Quote:
Originally Posted by chrisdh79 View Post
I had this issue from day one when I got my car last year. I took my car in when I got the transmission update, and they replaced the front sway bar links. Its been fine ever since!
chrisdh79,

Always happy to hear Focus owners good report!

Thanks all!

Noemi
__________________
FORD SERVICE

p: 800.392.FORD
t:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

f:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


M - F 11:30 a.m. - 8 p.m. ET | Send a PM? Pls allow 2 business days for reply
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
FordService is online now  
    Reply With Quote