Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - had a blast...
Thread: had a blast...
View Single Post
Old 09-01-2009, 04:08 PM   #3
WD40
The Librarian
 
WD40's Avatar
 
Join Date: Mar 2004
Fan#: 5157
Location: Helena, MT
What I Drive: '04 Sonic Blue - SVT 3Door

Posts: 13,116
Points 226,961, Level 100
Points: 226,961, Level: 100 Points: 226,961, Level: 100 Points: 226,961, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 139 WD40 Excellent Standing Member WD40 Excellent Standing Member
Buy-Sell-Trade Rating: (3)
Cool deal!
Sounds like a great turnout too.
I'd never have thought there were that many enthusiasts in the area.
Where was the furthest competitor from?

Next year, ya gotta some lights.
Are there any drag race venues near you that might have portable lights to loan out?

And vids of your runs?
Power steering...Get some Redline fluid in there!
Mine used to expand quite a bit to the point of almost reaching the cap.
Not so at all now since I put in the Redline stuff.

-------Off Topic------
I got back on the track this weekend too for an event down in Bozeman!
I was a bit rusty, but that feeling was gone once I went through the first gate!
__________________
WD40 Reverend GripShift - FF Moderator

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

WD40 is offline  
    Reply With Quote