Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - Where has CaysE's SVT been? Build thread time!
View Single Post
Old 06-03-2009, 04:58 PM   #173
zetecDon
Where am I?
 
zetecDon's Avatar
 
Join Date: Feb 2009
Fan#: 62506
Location: east of Cincinnati, OH
What I Drive: 02 ZX3, 02 MX-5, 09 Coupe

Posts: 8,774
Points 13,893, Level 76
Points: 13,893, Level: 76 Points: 13,893, Level: 76 Points: 13,893, Level: 76
Level Up 61% Completed
Level up: 61% Level up: 61% Level up: 61%
Forum Activity 90%
Activity: 90% Activity: 90% Activity: 90%
FF Reputation: 29 zetecDon Great Standing Member
Buy-Sell-Trade Rating: (50)
Quote:
Originally Posted by CaysE View Post
It wasn't so much forgetting parts... it's just that parts were missing from the used kit I bought. It's difficult to tell which parts I was missing until I got to a specific step and thought, "hmmm... none of these bolts fit." The rear bracket was a fail because I didn't realize it was two pieces... I had one of the pieces and thought that was all I needed.
Yeah I have a printout of all the parts that came with the JRSC so I could go through the box and see what was missing and sort through what wasn't supposed to be there. I bought mine used also from a fellow FF'er. Everything so far appears to be there but I am going to give it a more thorough look through once I decide to install it. I do know that I am going to need one hose that was cut some where along the process though but that isn't a big deal.
zetecDon is online now  
    Reply With Quote